Click here to Skip to main content
11,928,919 members (45,808 online)
Rate this:
Please Sign up or sign in to vote.
Hi everyone,

like the subject says, I am developing an aplication in wpf. The problem is when i try to run that app in another pc. .NET dependencies isn´t because i have .net client profile and extended.
What could be ? any ideas ?
Posted 18-Nov-11 5:18am

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

There can be many reasons why an app fails to run. perhaps it's missing dependency DLLs. It could be a permissions issue. Maybe resource files or other config files are missing. It may be using hardcoded paths. And with .NET apps, the target machine may not have the exact same framework version (including any SPs).
SAKryukov 18-Nov-11 11:08am
Good check list, a 5.
cristovao50 18-Nov-11 11:19am
well, I made a install setup project and added all files in bin/debug directory of wpf app.
setup only detected one dependency - .NET;

I install the setup in other computers and it installs just fine. The problem is when i try to run application, nothing happens.
Nishant Sivakumar 18-Nov-11 11:21am
You are releasing a debug-mode binary. You need to make a release-mode build and then distribute those files (/bin/release). The debug mode binaries are only meant for dev/debug/test work.
cristovao50 18-Nov-11 11:44am
its makes sense, I am going to try and after i leave some feedback...
cristovao50 18-Nov-11 13:14pm
problem solved, i was trying to load a wrong database ...

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy | Mobile
Web04 | 2.8.151126.1 | Last Updated 18 Nov 2011
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100