Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C# library Enterprise problem , +
Hi everyone,
 
In enterprise library 5 when i'm using App.Config with incorrect connectionString with name "test" and use this line:
Database DB = DatabaseFactory.CreateDatabase("test");
DB created successfully but when the following line executed there is a substantial delay followed by exception:
DataTable dt = DB.ExecuteDataSet(SPName, Params).Tables[0];
i'm asking about the substantial delay why ??!!!
Posted 28-Dec-12 11:50am

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

the delay is because it's trying to connect to a database that doesn't exist, at least i'm assuming that since you say the connection string is incorrect.
  Permalink  
Comments
AhmedYehiaK at 30-Dec-12 6:58am
   
I know that the delay because of incorrect connection string but it's not ordinary delay it's substantial delay that reach 1 min !!!!

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 350
1 Jochen Arndt 150
2 PIEBALDconsult 110
3 Richard MacCutchan 105
4 Sergey Alexandrovich Kryukov 104
0 OriginalGriff 6,055
1 DamithSL 4,621
2 Maciej Los 4,087
3 Kornfeld Eliyahu Peter 3,500
4 Sergey Alexandrovich Kryukov 3,294


Advertise | Privacy | Mobile
Web01 | 2.8.141220.1 | Last Updated 30 Dec 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100