Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: ASP.NET4.0
Hi,
 
We are working on an application which generates an MS word document and opens in the client machine where users can edit and save in the same server using Impersonation.
 
It worked in test environment but when moved to production it is giving problems.
When we logged into server generates a word document through UI and it is working fine but when we logged off from server it is throwing below exception.
 
Word experienced an error trying to open the file.
Try these suggestions.
* Check the file permissions for the document or drive.
* Make sure there is sufficient free memory and disk space.
* Open the file with the Text Recovery converter.
<filename>
 

 
Can any one help this how to solve the above issue.
Posted 16-Mar-13 2:40am
Edited 16-Mar-13 3:57am
Mike Meinz21.2K
v2
Comments
ThePhantomUpvoter at 16-Mar-13 9:24am
   
Okay first thing you need to do is: Check the file permissions for the document or drive
#2 Make sure there is sufficient free memory and disk space
#3 Open the file with the Text Recovery converter
#4 Debug your code
#5 Don't use Office products in unsupported configurations.
Prashant Bangaluru at 20-Mar-13 5:41am
   
Hi ,Thanks for your reply I checked the file permission and memory they are as in the test envi.
The only prob is when we log into server and try to generate it is working but we log off it is failing to regenerate.

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Your impersonated user(register either web.config or other way) has not proper permission in that directory in your production server. You just assign appropriate permissions to that directory to the impersonate user.
  Permalink  
Comments
Prashant Bangaluru at 20-Mar-13 5:37am
   
Hi ,Thanks for your reply We mentioned the user id and password in web.config but no use.Checked all file permission to the directory ,directory has got all the permissions I tried all the above options but not working..
S. M. Ahasan Habib at 20-Mar-13 6:17am
   
You set full permissions to Everyone(default user/group) at your directory and check it is working or not.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Kornfeld Eliyahu Peter 420
1 OriginalGriff 303
2 Yogesh Kumar Tyagi 230
3 Gihan Liyanage 99
4 sankarsan parida 90


Advertise | Privacy | Mobile
Web03 | 2.8.140827.1 | Last Updated 16 Mar 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100