Click here to Skip to main content
11,569,265 members (57,170 online)
Click here to Skip to main content

Tagged as

How to do SharePoint 2010 Content Deployment

, 31 Oct 2011 CPOL 14K 1
Rate this:
Please Sign up or sign in to vote.
There are many articles in the web by describing Content Deployment in SharePoint 2010. But most of the time (In my case it do not work fine always in first time :-( )  it is not working property and giving plenty of errors which direct us to restoring the backup rather than trying Content Deploymen

There are many articles in the web by describing Content Deployment in SharePoint 2010. But most of the time (In my case it do not work fine always in first time Frown | :-( )  it is not working property and giving plenty of errors which direct us to restoring the backup rather than trying Content Deployment in the SharePoint Server.

Here I'm going to my experiences and how I'm resolving those errors and little bit of background about the  SharePoint Content Deployment. Luckily i have manage to successfully proceed with the SharePoint Content Deployment most of the time.

What is SharePoint Content Deployment 

Content deploy can be use to export (deploy) content from one site collection to another site collection. content deployment is taking care of following contents in the source site collection.

  • Web pages – Deploy corresponding images styles , master pages and etc.
  • libraries
  • lists
  • resources

Content Deployment do not deploy

  • programs
  • assemblies
  • features
  • configuration information(Web.config)

Most of the time Content Deployment fails due to features. in the later i will explain how to over come these issues.

How to Configure SharePoint 2010 Content Deployment

We will use following scenario for the deployment

image

First you need to create a site collection in the production server (Our One is production/sites/ALR) which you are going to use in the content deployment.

When you are creating I'm always using site template as Select Template Later in the Custom Tab.You can use the blank template also but I'm recommending this one  because this one worked for me  all the times.

image

After that you need to configure content deployment

For than go to Central Administrator –> General Application Settings–> Configure Content Deployment in the Production Server

image

go to this and 

  • allow Accept incoming content deployment jobs in Accept Content Deployment Jobs section.

 image

  • select Do not require encryption  in connection security.(If you want you can use https also. but for the moment select the other one. )

image

Then Go to Development Server and proceed following steps to configure deployment path and job.

First we need to Configure Deployment Job. For that Go to Central Administrator of the development machine and then General Application Settings and  then Configure content deployment paths and jobs.

image

then select New Job to create new content deployment job.

Then Specify Title and Description (Optional) and for the source application select Source Web Application as Development and Source Site site collection  as  /sites/ALR ( this is as per scenario you can choose your one)

then you need to give production server Central Admin URL with the Port to Destination Central Administration Web Application. here i found that some times we need to give the with IP addresses. but most of the time URL will work.

image

Then we need to provide authentication information. here most users are failing in this point (I were also). because what ever the selection we made we have to provide user name and password. Earlier i thought if we select windows authentication it does not need but it is not. Following shows sample values for  Authentication Information

image

after that select the destination Web Application and Site collection in Destination web application and site collection section.

image

For the moment leave Deploy User Names selected and Security Information All.

The SharePoint Automatically Create a Quick Deployment Job for you.

image  

For the moment leave this and create a Deployment Job by right clicking the Deployment Configuration.

image

Here you can schedule the content deployment but for the movement select following options but of cause you can change them as you want later.

SQL Snapshots --> Do not use SQL Snapshot
Scope --> Entire Site Collection

the clink and finish the job creation. then you will see following kind of a menu.

image

Now the hard part comes. In the Menu Click Run Now or Test Job. (I’m Recommending Test Job before actually run the Job. Because some times Run Now deploy content partially and failed thus better to Test the Job before it is actually run. ) Then Most of the Time you will get Test Failed. If Not you are very lucky, thus you can proceed with the Run Now. But if you get Test Failed (sure you are Smile | :) ) Following are the workaround you can fixed those errors.

Following are the most common errors you are getting..

Could not find Feature someFeature.

This error coming because this feature is not in the Production Server. Thus Install the Feature to the production server and run the Test Job again, then it will say another feature is missing thus keep on adding or removing unnecessary features in the development machine until it get succeed. You can find more feature details by using  power shell commands (click here).  

Could not find Feature FT-01-bbb35132-7695-139b-2e18-27444285e766.

These features are InfoPath Form Template Features. Thus get the relevant Form template and upload it to the production server.  The run the Test Job and see the progress.

If every thing finds most of the time you are getting these kind of errors.

  • An unexpected error has occurred
  • A list, survey, discussion board, or document library with the specified title already exists in this Web site. Please choose another title.
  • Unable to import the folder _catalogs/fpdatasources. There is already an object with the Id d029169b-1f86-4275-bb99-dd78a48f7952 in the database from another site collection.

These errors are coming because content database is having these objects and those are orphan in the site collection. thus you can repair the content database to delete these orphan objects in the particular site collection. 

thus you can use following power shell command to get rid of these errors (click here).

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

Share

About the Author

Melick
Sri Lanka Sri Lanka
No Biography provided

You may also be interested in...

Comments and Discussions

 
-- There are no messages in this forum --
| Advertise | Privacy | Terms of Use | Mobile
Web03 | 2.8.150624.2 | Last Updated 31 Oct 2011
Article Copyright 2011 by Melick
Everything else Copyright © CodeProject, 1999-2015
Layout: fixed | fluid