If you meant the statements for one of the conditional result to be something of a placeholder, then a simple comment in that place denoting it to be such, would have been better than duplicating code.
OTOH, if you meant for the "else" portion to be FALSE, then your sloppiness is going to get you in a lot of trouble in the days and years ahead.
You have some good ideas, but you need to pay more attention to your work.
yea ! you have rightly pointed out the useless statement .Actually there was a problom in its continous multiplication and addition , i.e like 2+2+2+2 etc .then it was checking the state of the equal button . When i fixed that , i forgot to remove that !!!!
I just gave you another '5' for your enthusiasm and the ability to produce a workable program. You can use better file names/class names and use proper conventions naming the resource identifiers for example.
Just a thought, when I write my first calculator program, I was not not happy at that time with so many functions I have to add for every button. I liked to write concise code. I used ON_CONTROL_RANGE to write a single function for all the numberical buttons and used their labeled text to find out what is pressed. You don't need to do it that way but sometimes exercize like becomes a good programming lessons. At least it makes it a little more challenging to wrok on.