Click here to Skip to main content
Click here to Skip to main content
Technical Blog

Tagged as

Can the C# ‘var’ Keyword be Misused?

, 21 Jul 2011 CPOL
Rate this:
Please Sign up or sign in to vote.
More and more often I've been seeing C# code like this: var Data = GetData(); What on earth does GetData() return? This code is not as maintainable as it could be and is not as maintainable as it should be. Doesn't explicitly declaring the variable type make the code more readable, understandabl

More and more often I've been seeing C# code like this:

var Data = GetData(); 

What on earth does GetData() return? This code is not as maintainable as it could be and is not as maintainable as it should be.

Doesn't explicitly declaring the variable type make the code more readable, understandable and ultimately more maintainable?

DataTable Data = GetData(); 

Ahhh, GetData() returns a DataTable.

I know that var has uses but I wish it would have been named something much longer because typing 'var' is too easy. Perhaps it should have been named AutomaticTypeVar or even AutoVar to reduce the lazy misuse.

Just my 2 cents.

Steve Wellens

[Update]

A user on the Asp.Net forums was kind enough to provide this quote and link:

"However, the use of var does have at least the potential to make your code more difficult to understand for other developers. For that reason, the C# documentation generally uses var only when it is required."

http://msdn.microsoft.com/en-us/library/bb384061.aspx 

 

[Update II]

There seem to be a lot of lazy developers who are trying to justify and rationalize their lazy habits. 

Let's try a heuristic approach to see if the concept of maintenance can be better communicated:

var x = FunctionA();              // this is unacceptable

var x = GetCustomerID();          // better

var CustID = GetCustomerID();     // better but what is CustID?

String CustID = GetCustomerID();  // best.

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

Share

About the Author

Steve Wellens
EndWell Software, Inc.
United States United States
I am an independent contractor/consultant working in the Twin Cities area in Minnesota. I work in .Net, Asp.Net, C#, C++, XML, SQL, Windows Forms, HTML, CSS, etc., etc., etc.

Comments and Discussions

 
Question"Var" is good when it avoids redundancy; bad when it obscures needed information. Pinmembersupercat921-Jul-11 10:42 
AnswerRe: "Var" is good when it avoids redundancy; bad when it obscures needed information. PinmemberJaime Olivares1-Aug-11 16:12 
GeneralI agree -- I hate the trade-off of convenience vs. stability (or security) PinmemberBit-Smacker15-Jun-10 8:01 
GeneralI just had to... PinmemberTom Janssens6-Apr-10 7:47 
Soz, couldn't resist Wink | ;)
 
[edit]
I did vote a 5 Big Grin | :-D

GeneralAbout 'var' name PinmemberJaime Olivares19-Nov-09 19:24 
GeneralRe: About 'var' name [modified] PinmemberSteve Wellens1-Aug-11 16:04 
GeneralRe: About 'var' name PinmemberJaime Olivares1-Aug-11 16:08 
GeneralRe: About 'var' name PinmemberSteve Wellens1-Aug-11 16:10 
GeneralRe: About 'var' name PinmemberJaime Olivares1-Aug-11 16:19 

General General    News News    Suggestion Suggestion    Question Question    Bug Bug    Answer Answer    Joke Joke    Rant Rant    Admin Admin   

Use Ctrl+Left/Right to switch messages, Ctrl+Up/Down to switch threads, Ctrl+Shift+Left/Right to switch pages.

| Advertise | Privacy | Terms of Use | Mobile
Web02 | 2.8.1411023.1 | Last Updated 21 Jul 2011
Article Copyright 2009 by Steve Wellens
Everything else Copyright © CodeProject, 1999-2014
Layout: fixed | fluid