Click here to Skip to main content
Click here to Skip to main content

Tagged as

Go to top

Major Component Upgrades with a twist, benchmarks and all!

, 29 May 2013
Rate this:
Please Sign up or sign in to vote.
Attempting an upgrade can be rewarding, but without an OS re-install may end in tears!

Introduction

Last week I wrote an article about my GPU card starting to show signs of fatigue and how the replacement CPU cooler just didn't cut it. That article can be found at http://www.codeproject.com/Articles/586904/Gelid-Icy-Vision-Rev-2-GPU-Cooler.

I also had been tempted to upgrade as the computer itself had known faults (more later), and wasn't releasing enough performance for the hardware within. In the end I decided this was as good a time as any to do an upgrade, so it was time to give the credit card a battering once more.

In this article I will take you through the basics of the hardware upgrades, what the machine specification was before and after, as well as how the system benchmarks compared pre and post upgrade.

The twist in the title relates to the fact that on this occasion I planned on doing the upgrade without any full operating system reinstall. Why would I want to try this, well quite simple, I wanted to see how Windows 8 handled the changes, as well as save a lot of time having to re-install not only the OS, but all the software on the machine!

Hardware Selection

The computer as it stood was a reasonably well performing machine, after all it had a Core 2 Quad processor, 6GB RAM, a GTX580 GPU and both a 256GB SSD and a 2TB HDD, so it was no slouch. There were issues with the existing hardware that were limiting the machines performance. Both hardware specification and faults existed that really needed to be addressed. 

Fault #1 

The motherboard would not accept a DIMM module in Slot 4. I had originally purchased 4x2GB DIMMs, but found that no matter which DIMM module was placed in Slot 4, after a random period of time I would get the dreaded Blue Screen of Death with a memory code error. The DIMMs were all tested individually, running 2GB, then 4GB and then 6GB (and all swapped around) and never had any issues. Only populating Slot 4 introduced the error. The DIMM modules were also tested using MemTest86, but no issues were identified with them. 

Fault #2 

The machine would reboot itself if the GPU was put under full load after approx 30 seconds. Initially I thought this was temperature related, but the hardware diagnostics revealed that at the time of the reboot, the GPU was only sitting at around 45'C, well below its maximum rating. (80'C+). The machine would happily sit all day with the CPU Loaded at 100%. Even with the CPU at 0%, and the GPU loaded the machine would reboot. There were never any faults recorded in the event logs and never had any blue screens, and the event log just stated that the machine was cleanly shutdown. It was as if the power cable had been pulled from the back of the computer. A really annoying fault.

Both of these faults could relate to the motherboard, or one to the motherboard and the other to the GPU. There may have been an issue with the PSU, but given the other faults, I disregarded this as a candidate for the time being. 

Fault #3 / Annoyance #1

The SATA sockets were located on the motherboard right where the GPU card sat and these sockets were not on the edge of the motherboard, but on the board itself and having SATA cables plugged in necessitated bending the sockets over to get the plugs past the GPU card. As a result of this I actually broke the plastic sockets off the motherboard as can be seen below;

Limitation #1

The Motherboard was only a SATA-II specification and maxed out at 3Gb/S, I was running with a SATA-III (6Gb/S) SSD as my primary disk and was therefore not getting the maximum out of it.

Upgrade Selection 

In the end I decided that I would go with a CPU, MB, RAM and GPU upgrade. The table below shows the hardware selections.

Component Pre-UpgradedecisionPost Upgrade Product Links 
CaseZalman GS-1200retainZalman GS-1200 link 
PSUOCZ Stealth Xstream 2, 700WretainOCZ Stealth Xstream 2, 700Wlink 
MotherboardGigabyte GA-EP43T-USB3replaceAsus P8Z77-V Prolink 
CPUIntel Core 2 Quad Q9650 3GHzreplaceIntel Core i7-3770K, Quad Core 3.5GHz/3.9GHz Boost link 
CPU CoolerCorsair Hydro H80retainCorsair Hydro H80link 
RAM3x2GB Corsair XMS3replace4x8GB Corsair Vengeancelink 
GPUGainward GTX580 3GB PhantomreplaceGigabyte GTX690 4GBlink 
HDD 1OCZ Vertex4 256GB SSDretainOCZ Vertex4 256GB SSDlink 
HDD 2Seagate Constellation ES 2TBretainSeagate Constellation ES 2TBlink 
Optical DriveLG GH24NS50retainLG GH24NS50link 

Let The Upgrade Begin 

Don't Forget To Backup!

Even though I was planning to do no reinstall I thought it would be best still to backup my files. After all, I might have fried the SSD or ended up having to reinstall if the no reinstall approach didn't work. I simply copied all the files across onto the standard HDD so I had at least 2 copies of the data. I would then perform the upgrade with just the SSD until I knew it was all working, then plug in the second HDD with all the data. I could have also copied the data externally to my NAS box, but was a bit lazy on this occasion and didn't bother. I was feeling confident (or brave/stupid, take your pick).

WEI / Baseline Benchmarking 

After the backups were complete, I rebooted the machine and performed a series of initial benchmarks. This would give me something to compare the effectiveness of the upgrade. I also took snapshots of the Windows Experience Index. I won't go into any more of the benchmarking here, but we will pick up on that later in the article. 

The patient
It was time to get down to business. The computer was shutdown for the last time (in its present state) and all the cables unplugged from the full tower case, before lifting the monstrosity up onto the desk. It normally lives on the floor being a full tower case, as as you can see in the photo below, has clear evidence of dust accumulations on the front and side fan intakes.

After giving the external of the case a quick blast with the air duster and vacuum, the left and right enclosure covers were opened up to expose the innards.

As you can see in the image above, the CPU cooler is a closed loop liquid cooler with its own dedicated radiator.  The new CPU did come with a standard OEM fan/heatsink combination, but I decided to retain the original cooler as it pulls cold air directly from external to the case. As the CPU would probably spend most of its time fully loaded with folding@home, this would be better than just cooling with the warm air in the case.

In the above photo you can also see an additional case blower mounted just below the GPU. I fitted this as a precaution as the heat was building up below the GPU and thought this would maybe help with the Fault #2 listed at the start. This would not be refitted during the rebuild.

The next step was to disconnect all the cabling and strip out the existing CPU cooler and radiator, allowing me access to get the old motherboard out. 

Throughout the upgrade the PSU and SSD, HDD and optical drives would all remain in situ. The photo below shows the internals once the everything except the motherboard had been disconnected. 



Next step was to remove the motherboard and give everything inside a good clean. There was dust everywhere. Stuck in all the nooks and crannies and needed a bit off effort to dig some of it out, The air duster and vacuum made a good job of this. 

I also took advantage of the CPU cooler being removed to give its fans and radiators a good clean as they were all embedded with dust. As you can see below things are looking much better now. 

The Rebuild

The case was moved back onto the floor and put the case on its side. This would make fitting the motherboard, CPU and CPU Cooler a lot easier.

The first thing to do is check the motherboard mounting hole alignments align correctly with the mounts. It would not be too clever to blow it up on its first power up due to a short circuit!

The motherboard also came with a wireless adapter (802.11 b/g/n). I am using a wired gigabit network and didn't really need this, however I decided I would fit the card now as the mounting screw hole was underneath the motherboard, and wouldn't be able to get access to this later without a full strip down. I would just leave this disabled in the bios and if the wired network did fail for whatever reason I could always fall back onto wireless. I also thought that one day I could maybe run a segregated wireless network when experimenting with Arduinos or Raspberry Pi's.

The image below shows the wireless adapter fitted onto the motherboard. 

 

The motherboard was subsequently mounted into the case, the cpu installed in the socket, the CPU cooler radiator/fans and cpu block all mounted into place.

All cables were hooked up and threaded neatly where possible through the various case holes. There was also a supplied rear back plate for 2 x USB2 and 1 x eSATA connector which was fitted to the lowest case slot.

Next step in the rebuild was to fit the memory, mount the GPU, re-install a secondary USB card I have to give extra ports and hook up the power connectors to the GPU.

The new GPU had 2x8Pin sockets, but my old GPU and PSU only have 1x8Pin and 1x6Pin plugs. I had to use a Molex to 8 Pin adapter which was supplied with my previous GPU card.

 

And the rebuild is complete!

Power Up Time

As with anything like this, the initial power on moment usually is best done with the case open. This allows you to see if smoke starts appearing, fans are turning correctly etc.

Heart Stopping Moment #1

With everything ready to go, I hit the power button. The machine powered up, and after about 5 seconds, it went off again, silence, PANIC! I sat focused on the computer wondering what has gone wrong and after about another 5 seconds the machine started itself up again......bizarre is an understatement. Don't know if the BIOS was doing some magic behind the scenes, but it certainly had me worried for a moment. 

Heart Stopping Moment #2 

As the display kicked into life, I noticed that the SSD was not appearing. It was definitely connected. If you look at the motherboard images above you will see the SATA sockets are Dark Blue, Grey and Blue, the Dark Blue and Grey are the SATA-III and the Blue are the SATA-II, it shouldn't matter where the SSD is connected, it should still be found. Turns out that the Dark Blue ports must be configured differently (still haven't looked in the manual yet to see why), but moving the SSD to the Grey ports worked. And there it has been left for the time being. 

Operating System Startup

I was running Windows 8 Pro x64 and as I said at the start I wasn't planning on doing a reinstall. Once the BIOS had recognised the SSD, windows booted up and immediately displayed a message saying that it was configuring hardware. This took a few minutes, but once complete the machine happily booted up to the Login prompt. Entering my usual password etc and clicking on 'Desktop' on the start screen, and everything appeared to be normal. Fired up a Chrome browser session and navigated to the internet and all was working fine.    

That is certainly more pleasant than having to spend the next couple of days re-installing and getting everything back to normal!

Benchmarking

Windows Experience Index (WEI)

The first benchmarks available and built into windows is of course the Windows Experience Index.  On Windows 8 the WEI is a number that ranges from 1 to 9.9 and the lowest category rating determines the overall rating.

When I first compared the WEI score against the pre-upgrade score, I did notice that the two scores relating to graphics were lower for the new GPU. Something was not quite right. Initially I thought that perhaps the GPU was limited in performance for one of two reasons, 1) I noticed a system performance setting in the BIOS and this was set to normal or 2) the card was throttling back its own performance and there was no demand on it.

In the photo of the BIOS screen, you can see the system performance selector in the middle, set to normal. I selected the high performance option (right hand option with the flames) and rebooted the machine to see the difference this time.

  

Unfortunately, this made no difference. The WEI score was still lower than pre-upgrade. My next thought was that the graphics drivers installed were slightly different due to the different cards and decided to reinstall the Nvidia drivers. Having checked on the NVidia website, I actually found there was a new release of the drivers available, so downloaded and installed those. Gave the machine a reboot to ensure everything was in order and checked the WEI score again. This time the score jumped up and looked better!

The WEI scores for Pre-Upgrade, Pre- GPU Driver Reinstall and Final are shown below:

As expected, all sub-scores were now higher than the original specification.

PC-Mark 7

The next set of benchmark we will look at were taken using the free basic version of PC-Mark 7. The version number was V 1.4.0 and it clearly states on the website that "Benchmark scores are affected by the changes in this update and you should not compare scores from PCMark 7 v1.4.0 with any previous version." 

The results of the benchmarks were:

Pre-Upgrade:4237full results[^]
Pre-GPU Driver Reinstall:6123 full results[^]
Final Upgrade Score:6159 full results[^

Note: The links will take you to the results table as stored automatically by the benchmark software on the vendors website. 

RDII Disk Benchmark

The final set of benchmarks we will look at is my old favourite, the RdII disk benchmark.  This is a simple disk benchmark tool written by Ives Heymans, and released as freeware. It is a .NET application. This application does have the facility to use unbuffered IO, which means that system caches etc., should not interfere with the results and the disk's own caching and buffering can do their thing as if it was just a normal drive. You can see in the image below, the option to use unbuffered IO and also the set size selector. It is simply a case of then double clicking the drive letter you want to benchmark.

I ran the benchmark for both the SSD and HDD with data sets of 20MB, 100MB, and 500MB and ran these three times and took the average result. This was done for both the pre-upgrade and post-upgrade. The full benchmark results are available in the Excel attachment, but I have simply shown the results of the 500 MB dataset comparison below.  

As you can see switching the SSD from the SATA-II to SATA-III has made a significant change to the drives performance, particularly the READ (blue solid vs blue dash). The strange thing to note from the benchmarks however was on the standard hard disk. The READ performance of this drive actually reduced slightly across its full block size test range. I am not sure why this is, but will maybe have to do some further investigation at a later date. It is not a significant change, but it is still something I did not expect.

Software Activation 

An interesting thing to note was that Windows did not ask to be re-activated, despite having had major components replaced.

Microsoft Office 2010 on the other hand did request to be re-activated. 

As a precaution, in iTunes, I de-authorised the computer before the upgrade and re-authorised post upgrade. I am pretty sure that changing out the motherboard would have made iTunes think it was working with a different computer. I remember doing something similar year ago and as such have 2 out of 5 authorisations used instead of 1 one my account. 

Summary

It is safe to say that the upgrade was a success and on the whole went relatively smoothly. It made a real difference not having to re-install the full operating system again and then install all my software like Office and Visual Studio. 

Now I just need to put the machine to use! 

As for the old components, I think I have another little project planned for them. I have always fancied building a totally submersed PC, i.e. an mineral oil fish tank, I might track down a suitable replacement motherboard and put the old CPU and ram to use. Maybe a future article! 

History

  • 10th May 2013 - first release
  • 30th May 2013 - typos and rewording  

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

Share

About the Author

DaveAuld
Engineer
Scotland Scotland
I have been working in the Oil & Gas Industry for over 20 years now.
 
Core Discipline is Instrumentation and Control Systems.
 
Completed Bsc Honours Degree (B29 in Computing) with the Open University in 2012.
 
Currently, Offshore Installation Manager for the Beryl Bravo platform, which is located ~180 miles NE of Aberdeen, Scotland in the Northern North Sea.
Formely on the Forties Charlie platform, which is located ~110Miles NE of Aberdeen.
Follow on   Twitter   Google+   LinkedIn

Comments and Discussions

 
GeneralMy vote of 5 PinmemberBillWoodruff26-Jun-13 3:25 
GeneralRe: My vote of 5 PinprotectorDaveAuld26-Jun-13 4:09 
QuestionI can't believe that I found this article PinmemberSteve Erickson29-May-13 13:57 
QuestionExcellant article and an awesome machine PinprofessionalMike Hankey10-May-13 14:51 
but damn your eyes now I have the Hardware Upgrade Acquisition Syndrome (HUAS). Smile | :)
VS2010/Atmel Studio 6.1 ToDo Manager Extension
Some days, it's just not worth chewing through the restraints.

AnswerRe: Excellant article and an awesome machine PinprotectorDaveAuld10-May-13 22:07 

General General    News News    Suggestion Suggestion    Question Question    Bug Bug    Answer Answer    Joke Joke    Rant Rant    Admin Admin   

Use Ctrl+Left/Right to switch messages, Ctrl+Up/Down to switch threads, Ctrl+Shift+Left/Right to switch pages.

| Advertise | Privacy | Mobile
Web02 | 2.8.140916.1 | Last Updated 30 May 2013
Article Copyright 2013 by DaveAuld
Everything else Copyright © CodeProject, 1999-2014
Terms of Service
Layout: fixed | fluid