Click here to Skip to main content
Click here to Skip to main content

Step-By-Step installing Sharepoint 2013 Using AutoSPInstallerGUI

, 27 Jul 2013
Rate this:
Please Sign up or sign in to vote.
CodeProjectIn earlier post we dealt with Issues while Installing and Issue in hosting App model in SharePoint 2013. We can avoid most of these issues by using AutoSPInstaller. Its a batch file which triggers a series of powershell commands, which reads configuration data from an xml file and install
In earlier post we dealt with Issues while Installing and Issue in hosting App model in SharePoint 2013.

We can avoid most of these issues by using AutoSPInstaller.

Its a batch file which triggers a series of powershell commands, which reads configuration data from an xml file and installs SharePoint 2013 and all other supporting components.

Even though AutoSPInstaller made installation easy, but still we have a pain point. Configuration.

Now we have a AutoSPInstallerGUI, as simple web application specially designed for SP 2010 and 2013 installations. This will make our lives easy dealing with configuration part.

All you need to do is download #1. AutoSPInstaller and #2. AutoSPInstallerGUI from respective links.

AutoSPInstaller has all the required batch files, configuration files, Powershell script files, and pre-requisite installer files.

AutoSPInstallerGUI has a simple windows application, using which we modify the installer file in AUtoSPInstaller.


If this is so simple, why I am writing this post!

There are some common mistakes that we need to avoid and Common practices we need to follow for creating a better environment for our usage.

Even after using all the above mentioned stuff, some of us may be stuck with some issues like

- Creating SQL alias "SPSQL"...
- Testing access to SQL server/instance/alias: SPSQL
- Trying to connect to "SPSQL"... - Fail
--------------------------------------------------------------
- Script halted!
- Connection Error. Check server name, port, firewall.
Press any key to exit...                     (Resolution: Refer to #5 mentioned below)

or

- SharePoint 2013 setup completed in 00:00:25.
WARNING: 2013/07/07 11:15:05:907::[4632] Error: Invalid Product Key Type: 30::InvalidCDKey.
--------------------------------------------------------------
- Script halted!
- Review the log file and try to correct any error conditions.
Press any key to exit...                   (Resolution: Get correct Key)

or

- Creating Site Collection http://MACWIN2K12:8080...
--------------------------------------------------------------
- Script halted!
 
Exception : Microsoft.SharePoint.SPException: User cannot be found


 (Resolution: Refer to #4 mentioned below)
or

- Restarting service SPTraceV4...
--------------------------------------------------------------
--------------------------------------------------------------
- Provisioning Enterprise Search...
--------------------------------------------------------------
- Script halted!
 
Exception : System.Management.Automation.ParameterBindingValidationException: Cannot bind argument to
parameter 'String' because it is an empty string.      

(Resolution: password missing for one of the accounts in config file)

One good thing about AutoSPInstaller is, you can simply re-run the whole script to make if work after your corrections. You doesn't need to rollback anything to re-run.

So, please follow the below steps and practices to create SP 2013 machine.


Please follow the instructions mentioned in here

But please read below instructions before doing any of that stuff.

#1. Copy the SharePoint 2013 installables to SP folder in "~/AutoSPInstaller\SP\2013\SharePoint" folder.
#2. Create all the Required accounts before hand.
#3. Never Modify AutoSPInstallerInput.xml. Load xml from AutoSPInstallerInput.xml and save as that file in the same folder with name of your choice. And then start doing modifications and Save them to your Custom xml file.
#4. Once you are done with updating your custom input xml file. Don't just run the batch file. Open the XML file and search with "DOMAIN". There may be some configuration details which are not visible in GUI and still can stop installation giving one of the above exceptions.
#5. Install SQL Server 2012 before SharePoint 2013, and make a note of the instance name. That need to be given in Farm configuration details. Check the connectivity to DB server by pinging.
#6. Don't give any DB Server name in any of the configurations unless you want it to be different from Farm DB Server. Leave server name text boxes blank if you want to use same DB Server for all the purpose. Thus configuration will use Server mentioned in Farm tab for all the purposes.
#7. In "Service Applications" tab provision text box takes true / false. If you give false, automatically all the options of a specific service application will be disabled.

#8. Don't execute the "AutoSPInstallerLaunch.bat" by double clicking. By default it was configured to AutoSPInstallerInput.xml, the file which we use as reference. After you are done with all configuration, drag the custom configuration xml file (Farm1.xml in my case) to AutoSPInstallerLaunch.bat file. Now it executes by taking our custom xml file as input file.

Here are snapshots of my configuration using AutoSPInstallerGUI. Please note that your configuration changes as per your requirement and I am providing below screen shots just for verification purpose.























Once after all our efforts, Good News.

- Running all Health Analyzer jobs...
- Completed!
- Launching Central Admin...
- Launching http://MACWIN2K12..
- Launching http://MACWIN2K12:8080...
-----------------------------------
| Automated SP2013 install script |
| Started on: 7/7/2013 12:09:47 PM |
| Completed: 7/7/2013 12:31:41 PM |
-----------------------------------
**********************
Windows PowerShell transcript end
End time: 20130707123241
**********************
 

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

About the Author


Comments and Discussions

 
QuestionDatabase fail to connect when running the script PinmemberMember 102625839-Sep-13 7:42 
AnswerRe: Database fail to connect when running the script PinmemberPratapReddyP11-Sep-13 16:53 
QuestionI need help with some of the steps. PinmemberMember 1020562412-Aug-13 17:54 
AnswerRe: I need help with some of the steps. PinmemberPratapReddyP12-Aug-13 18:01 
QuestionRe: I need help with some of the steps. PinmemberMember 1020562412-Aug-13 20:42 
QuestionRe: I need help with some of the steps. PinmemberMember 1020562412-Aug-13 21:46 

General General    News News    Suggestion Suggestion    Question Question    Bug Bug    Answer Answer    Joke Joke    Rant Rant    Admin Admin   

Use Ctrl+Left/Right to switch messages, Ctrl+Up/Down to switch threads, Ctrl+Shift+Left/Right to switch pages.

| Advertise | Privacy | Mobile
Web03 | 2.8.140721.1 | Last Updated 27 Jul 2013
Article Copyright 2013 by PratapReddyP
Everything else Copyright © CodeProject, 1999-2014
Terms of Service
Layout: fixed | fluid