Click here to Skip to main content
12,452,344 members (54,766 online)

WTL and Visual Studio.NET

Source: The Code Project     Posted by Chris Maunder    Sunday, March 25, 2001 6:00pm    
Next version of WTL to support Visual Studio.NET

Nenad Stefanovic has confirmed that the next version of WTL will support Visual Studio.NET. The current versions (3.0 and 3.1) will still work with ATL7, but you will need to define _ATL_TMP_IMPL2 and ignore some compiler warnings. From his posting in the ATL mailing list:

WTL 3.0 and 3.1 are not designed for ATL7 (from Visual Studio.NET). However, you can build your projects if you define _ATL_TMP_IMPL2. You can also ignore the warnings about deprecated methods as they are just telling you that there is a better method to use, not that the one used is wrong. Next version of WTL will support Visual Studio.NET.
There is also further information on the availability of WTL:
In addition to the Platform SDK, WTL 3.1 is now also available on the MSDN Downloads. Just go to http://msdn.microsoft.com/downloads, and find WTL under the "Visual Studio, Tools and Languages" \ "Visual C++" category.



Back to all news items


Advertise | Privacy | Mobile
Web02 | 2.8.160826.1 | Last Updated 10 Aug 2007
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid