Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C#
Unable to copy file "obj\Debug\.exe" to "bin\Debug\.exe". The process cannot access the file 'bin\Debug\.exe' because it is being used by another process.
 
Please help!
 
I have opened the task manager and I have ended the process but the same error appears.
 
I am using a window application.
 
Thanks in AdvanceRose | [Rose] Rose | [Rose] Thumbs Up | :thumbsup:
Posted 11-Oct-10 0:43am
aayu2.4K
Edited 11-Oct-10 0:48am
Dalek Dave432.9K
v3
Comments
Dalek Dave at 11-Oct-10 5:48am
   
Edited for Grammar and Readability.
PumbaPumba at 11-Oct-10 5:58am
   
Are you using VS2010?
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

Try to close down VS completely and start it up again. If that doesn't work, you need to restart your development computer...
  Permalink  
Comments
Aarti2010 at 11-Oct-10 6:45am
   
hey thanks i got it
PumbaPumba at 11-Oct-10 7:02am
   
This is a troublesome bug in VS2010. What I'll do is, close all the edited/opened files, then build the solution. It'll work. Else, I'll have 2 debugging modes "Debug" and "Debug-xml". If I get this in "Debug" mode then I'll change the mode to "Debug-xml" and build and run. If any other those didn't help. Then, as Jhonny said I'll re-start the VS.
Johnny J. at 11-Oct-10 7:23am
   
It's not only VS2010 - I think they must have ported the bug from VS 2008, because it exists there too... :-)
Aarti2010 at 11-Oct-10 7:31am
   
i am using VS2008 and i was facing this problem because of auto generate sequence number code.
   
Your app isn't shutting down correctly. It's not a bug in the IDE - at least not that I've ever experienced.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

You can restart your computer Big Grin | :-D
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

It's happening because you'r currently running the application (or it didn't shutdown completely the last time you tested it).
 
Go into task manager, and shut it down manually if you don't have a taskbar icon.
  Permalink  
Comments
Aarti2010 at 11-Oct-10 5:53am
   
i did that but then also same problem :(
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 6

Go to your services (where you are running the service) and Stop the service .And Restart the service then you may solve your problem
  Permalink  
Comments
VICK at 20-Mar-14 1:36am
   
Logic to answer an already answered and longgggggg old question?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Maciej Los 295
1 OriginalGriff 273
2 Aajmot Sk 234
3 Marcin Kozub 205
4 Richard MacCutchan 200
0 OriginalGriff 7,903
1 Sergey Alexandrovich Kryukov 7,127
2 DamithSL 5,604
3 Manas Bhardwaj 4,986
4 Maciej Los 4,820


Advertise | Privacy | Mobile
Web04 | 2.8.1411023.1 | Last Updated 19 Mar 2014
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100