Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: IIS7
there is a web site which was hosted in iis6 and worked very well, when i wanted to host it in iis7, I faced a lot of problems BTW .
I think the problem is about ashx files in which AjaxPro works, but iis does not let these files be loaded.
I have tried these :
1 : I've changed application pool to classic or integrated mode. ( no different)
2 : I've added this code to web config
 
<configuration>
 
    <location path="ajaxpro">
        <system.webServer>
            <handlers>
                <add verb="*" path="*.ashx" name="AjaxPro"
                     type="AjaxPro.AjaxHandlerFactory,AjaxPro.2" />
            </handlers>
        </system.webServer>
    </location>
 
</configuration>
Posted 9-Nov-10 4:20am
Edited 9-Nov-10 4:34am
Henry Minute223.8K
v2
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

hello ;
Windows 2008 \ IIS 7 doesn't have the axd handler mapping set up by default for using Ajax so you need to put the following code into your web.config file if you want to use Ajax and are on one of our Windows 2008 hosting plans.
 

<system.webServer>
        <handlers>
            <add name="Ajax" path="*.axd" verb="*" modules="IsapiModule"
scriptProcessor="C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll"
resourceType="Unspecified"
preCondition="classicMode,runtimeVersionv2.0,bitness32" />
        </handlers>
</system.webServer>
or copy the .dll to the bin folder and try that:
<httpHandlers>
<add verb="POST,GET" path="ajax/*.ashx" type="Ajax.PageHandlerFactory, Ajax"/>
 
</httpHandlers> in <system.web>
  Permalink  
Comments
sjms at 18-Dec-10 10:32am
   
thanks for answring me
Ashish Dev1 at 29-Mar-12 7:17am
   
Is your problem resolved? I had tried the solution given but problem still not resolved. Is there any other thing should be tried?
P Ranjan at 30-Aug-12 3:49am
   
No it does not work for me, tried the both settings in web.config. IIS7 on window7 64bit. I get the javascript alert that the class (Ajax front end wrapper for the page) was not not defined.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 4

  Permalink  
Comments
sjms at 18-Dec-10 10:32am
   
thanks for answring me
Member 7971918 at 27-Jul-11 5:04am
   
Thank you tamerqatar and Michael Schwarz
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 5

Hi,
 
I am facing same issue.
 
If you have fixed this issue then please let me know asap.
 
Thanks,
Mayur
  Permalink  
Comments
sjms at 26-Dec-11 10:19am
   
turn your apllication pool to classic mode.
sjms at 26-Dec-11 10:20am
   
and allow asapi frame work 4
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 6

Simply add new script maps in Handler Mappings of website in IIS Manager with the following:
 
Request Path: *.ashx
Executable: C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll
 
Mine worked with this solution.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 7,903
1 Sergey Alexandrovich Kryukov 7,192
2 DamithSL 5,604
3 Manas Bhardwaj 4,986
4 Maciej Los 4,820


Advertise | Privacy | Mobile
Web03 | 2.8.1411023.1 | Last Updated 11 Mar 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100