Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: ASP.NET VB.NET
Hi
 
I'm working on a VB.net web app. I'm generating an Excel workbook dynamically using Interop.Excel.Application. I'm getting a COM Exception
when new instance of Excel.Application is created. I've given access permissions in DCOM Config also. How Can I get rid of this exception?
 
Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 80080005 Server execution failed (Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_FAILURE)).
 

Please help me.
 
Thanks in advance,
Vanathi
Posted 8-Dec-10 23:22pm
Edited 9-Dec-10 0:29am
Slacker00772.3K
v2
Comments
Slacker007 at 9-Dec-10 6:29am
   
I shortened the question title because it was too long and because you mentioned the error in your question title and in the body of your question.
prerakpatel at 10-Dec-10 4:29am
   
More description required how you configured the security and identity settings.
Bernhard Hiller at 23-May-12 3:55am
   
Where do you want to create the Excel workbook - on the Web Server or on the Client?
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

I had the same error while using the CorelDRAW .tkl in a web app running on IIS 7.5 on my Win 7 64bit machine. I was able to solve it by adding the web user (IUSR) to the CorelDRAW DCOM component and granting local launch and activation permissions. I also had to change the setting under the Identity tab from 'The launching user' to 'The interactive user'.
 
This article was helpful, but was not written for win 7. http://blog.crowe.co.nz/archive/2006/03/02/589.aspx
  Permalink  
Comments
xellow2 at 5-Apr-13 13:12pm
   
Hello there, sorry for disturbing you, but i am building similar aplicacion with corel. I am doing an aplication where i use corel in the server side. I did the same as you. But still having that problem. How exactly i have to deploy my aplication using corel. I have windows 7 64 bits, and i know the com corel are 32 bits. Please need your help.
Member 8544310 at 9-Apr-13 12:13pm
   
It's been a while since I did this, and I am no longer on this project. From what I remember there is both 32 and 64 bit DOM configurations. You may need to figure out what user your application is using to access the file via IIS (it may not be IUSR) and give that user permissions. It may help to change the build of your application - try 32, 64 and mixed to see what works. Also, you will need corel installed on the machine that runs the program. Other that that try different configurations in DCOM until you get it working. Hopefully that is helpful.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 5

1) Run the considered app which the com exception was created on it(e.g your app or VS) as administrator
 
2) NOT Fixed, check your DCOM settings
 
1) Run dcomcnfg open Component Services
2) Expand Component Services "->" Computer "->" My Computer "->" the DCOM configuration "
3) Find the "Microsoft Excel application."
4) Right to open the Properties dialog box
5) Click on the "Security" tab,
6) "Launch and Activation Permissions, configure permissions, have opted for a custom
7) Their editing and then click the considered app added to it, and added all the permissions ...
 
3) Not Fixed, register the excel by regsvr32 or reinstall VSTO
 
Suggestion:
Use Office Open XML to create your files instead of automation. There are several libraries out there that will help you build Excel files. I personally use EPPlus and think it's pretty decent.
  Permalink  
v4
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Did you set the security and identity both in DCOM config?!
  Permalink  
Comments
Vanathi.A at 9-Dec-10 11:42am
   
yes.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

how to set the security and identity both in DCOM config and what to set in it...??
  Permalink  
Comments
Vanathi.A at 17-Mar-11 12:51pm
   
Hi,
 
You can easily do so..
 
1. In start menu select Run .
2. Type dcomcnfg and click OK
3. Component Services window is opened.
4. Expand the nodes Component Services -> MyComputer -> DCOM Config .
5. Right click on the application that you want and select properties.
(In my case it is Microsoft Excel Application ).
6. Microsoft Excel Application properties dialog box is opened.
7. Click on Security tab or Identity tab whatever necessary.
8. Click on the link " Learn more about setting these properties ."
 
All necessary details you need are provided there :)
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 4

I also got the same error for COM component...
 
ERROR:
Retrieving the COM class factory for component with CLSID {8885370D-B33E-44B7-875D-28E403CF9270} failed due to the following error: 80080005 Server execution failed (Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_FAILURE)).
 
I tried many of the solutions, i.e. those given above and also some other from msdn site... But finally, this solved the problem..
 
Opened Visual studio as a normal user (and not as an Administrator).
 
Mark it if u find this useful.
~~SATZ~~
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Sergey Alexandrovich Kryukov 480
1 mhegazy94 460
2 Ravi Bhavnani 190
3 Kornfeld Eliyahu Peter 185
4 Shemeemsha RA 160
0 Sergey Alexandrovich Kryukov 7,205
1 OriginalGriff 6,801
2 CPallini 5,350
3 George Jonsson 3,644
4 Gihan Liyanage 2,797


Advertise | Privacy | Mobile
Web02 | 2.8.140922.1 | Last Updated 3 Dec 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100