Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: IIS7 .NET3.5 ASP.NET
I have a hosting on godaddy that supports IIS7, and I uploaded a simple .net application (3.5) and getting the error (500 (Internal Server) Error) the godaddy support told me to update my web.config but still getting the sane error, here is my web.config file.
 
<?xml version="1.0"?>
<configuration>
  <configSections>
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
      <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
        <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
        <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
          <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere"/>
          <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
          <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
          <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
        </sectionGroup>
      </sectionGroup>
    </sectionGroup>
  </configSections>
  <appSettings/>
  <connectionStrings/>
  <system.web>
    <!-- 
            Set compilation debug="true" to insert debugging 
            symbols into the compiled page. Because this 
            affects performance, set this value to true only 
            during development.
            Visual Basic options:
            Set strict="true" to disallow all data type conversions 
            where data loss can occur. 
            Set explicit="true" to force declaration of all variables.
        -->
    <pages>
      <namespaces>
        <clear/>
        <add namespace="System"/>
        <add namespace="System.Collections"/>
        <add namespace="System.Collections.Generic"/>
        <add namespace="System.Collections.Specialized"/>
        <add namespace="System.Configuration"/>
        <add namespace="System.Text"/>
        <add namespace="System.Text.RegularExpressions"/>
        <add namespace="System.Linq"/>
        <add namespace="System.Xml.Linq"/>
        <add namespace="System.Web"/>
        <add namespace="System.Web.Caching"/>
        <add namespace="System.Web.SessionState"/>
        <add namespace="System.Web.Security"/>
        <add namespace="System.Web.Profile"/>
        <add namespace="System.Web.UI"/>
        <add namespace="System.Web.UI.WebControls"/>
        <add namespace="System.Web.UI.WebControls.WebParts"/>
        <add namespace="System.Web.UI.HtmlControls"/>
      </namespaces>
      <controls>
        <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
      </controls>
    </pages>
    <!--
            The <authentication> section enables configuration 
            of the security authentication mode used by 
            ASP.NET to identify an incoming user. 
        -->
    <authentication mode="Windows"/>
    <!--
            The <customErrors> section enables configuration 
            of what to do if/when an unhandled error occurs 
            during the execution of a request. Specifically, 
            it enables developers to configure html error pages 
            to be displayed in place of a error stack trace.
        <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
            <error statusCode="403" redirect="NoAccess.htm" />
            <error statusCode="404" redirect="FileNotFound.htm" />
        </customErrors>
        -->
    <httpHandlers>
      <remove verb="*" path="*.asmx"/>
      <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
      <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
      <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>
    </httpHandlers>
    <httpModules>
      <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    </httpModules>
    <customErrors mode="Off"/>
    <compilation debug="true"/>
  </system.web>
  <system.codedom>
    <compilers>
      <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" warningLevel="4" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
        <providerOption name="CompilerVersion" value="v3.5"/>
        <providerOption name="OptionInfer" value="true"/>
        <providerOption name="WarnAsError" value="false"/>
      </compiler>
    </compilers>
  </system.codedom>
  <!-- 
        The system.webServer section is required for running ASP.NET AJAX under Internet
        Information Services 7.0.  It is not necessary for previous version of IIS.
    -->
  <system.webServer>
    <httpErrors errorMode="Detailed"/>
    <asp scriptErrorSentToBrowser="true"/>
  </system.webServer>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/>
        <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/>
        <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/>
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
</configuration>
 
can any one help?
 
[edit]Code block added to preserve formatting, "Ignore HTML..." option disabled - OriginalGriff[/edit]
Posted 26-Feb-11 23:03pm
Edited 26-Feb-11 23:08pm
v2
Comments
digital man at 27-Feb-11 4:12am
   
What did they tell you to add? Is this a 'trust' issue, e.g.
Mohammad Al Hoss at 27-Feb-11 4:20am
   
They asked to update thses sections
CUSTOMERRORS mode="Off"
COMPILATION debug="true"
HTTPERRORS errormode="Detailed"
asp scriptErrorSentToBrowser="true"
They told me that the problem is in my web.config, note that the application is wroking well on my PC
digital man at 27-Feb-11 4:26am
   
So, you made the changes they told you to make and it still didn't work? Try stripping the file back to bare bones against a minimal site.
Mohammad Al Hoss at 27-Feb-11 4:29am
   
Can you explain more please.
digital man at 27-Feb-11 4:35am
   
Create a one page site thathas a web.config that has only the barest of entries and see if that works. Have GoDaddy said that they know what the problem and jsut aren't telling you?
Mohammad Al Hoss at 27-Feb-11 4:41am
   
They renamed the file and the site worked well, so they said the problem is form the web.config but they did not say which part of the file.
my site URL is "http://www.mohammadalhoss.com/" note that it is a one file application it only holds default.aspx
digital man at 27-Feb-11 5:23am
   
1: Comming - No! Coming - Yes!
2: If it works then put back one a line at a time form your web.confog till it fails. Then you'll know where the problem was.
Mohammad Al Hoss at 27-Feb-11 5:47am
   
I did that and i worked thanks for your help
digital man at 27-Feb-11 5:57am
   
You might want alter your post to say it is fixed and let us know what the problem was in case others have the same issue.
Sandeep Mewara at 27-Feb-11 4:23am
   
Did you talk with Goddady support again?
Mohammad Al Hoss at 27-Feb-11 4:28am
   
Yes I did and they gave me the same answer, just update the web.config.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

It may be problem for IIS 7.0 using the Application Pool integrated pipeline mode.
 

1) Try this in web.config file.
 
<system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
</system.webServer>
 
  Permalink  
Comments
Dalek Dave at 27-Feb-11 6:55am
   
good call
_Ashish at 1-Mar-11 12:37pm
   
Thanks
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

I replaced the root folder web.config file with this one
 
<configuration>
  <system.web>
    <compilation defaultlanguage="c#" debug="true" />
  </system.web>
  <appsettings>
    <add key="ConnectionInfo" value="server=(local);database=Northwind;Integrated Security=SSPI" />
  </appsettings>
  <system.webserver>
    <validation validateintegratedmodeconfiguration="false" />
  </system.webserver>
</configuration>
and i did not get the error any more.
  Permalink  
v3
Comments
Dalek Dave at 27-Feb-11 6:57am
   
Edited for code block
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

I face same problem with godaddy server i just change asp.net version 4.0 to 3.5(from iis management).... and problem was solve....
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 245
1 Jochen Arndt 155
2 PIEBALDconsult 150
3 Afzaal Ahmad Zeeshan 120
4 DamithSL 115
0 OriginalGriff 5,695
1 DamithSL 4,591
2 Maciej Los 4,012
3 Kornfeld Eliyahu Peter 3,480
4 Sergey Alexandrovich Kryukov 3,190


Advertise | Privacy | Mobile
Web04 | 2.8.141220.1 | Last Updated 27 Mar 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100