Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
Hi,
 
I created a simple DLL using ATL Project Wizard with one simple class added (of Simple ATL Object type) under MS Visual Studio 2008 (C++).
 
The solution was built fine and dll registration went successfully.
 
However when I tried to create new ActiveXObject() in JavaScript the WSH 5.8 aborts with the following message: "Automation server can't create object". The script is not used in under any browser.
 
After I tried the same script on other Windows 7 machine with WSH 5.7 (!) script went through successfully.
 
Can anyone please help me with this issue since my project demand to stick with Windows 7 and WSH 5.8 WSH.
 
Thank you,
Brad
Posted 7-Mar-11 10:27am

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Problem solved. The issue was about the dll built for x32 platform. Running the script on x64 platform resulted the problem while loading the dll. WSH 5.7 on x64 platform still runs in x32 mode which explains why the script was successfully loading the dll. On the other hand WSH 5.8 runs in x64 mode. Once the dll was rebuilt for x64 the script went through successfully under 5.8 as well.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



Advertise | Privacy | Mobile
Web04 | 2.8.1411022.1 | Last Updated 8 Mar 2011
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100