Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C# install
Hello Everyone,
Please guide me to this error I received whenever I run the application made using C#, the catch is, it is working in other computers but returns an error in one computer:
This is the error:
System.BadImageFormatException: Could not load file or assembly 'System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The module was expected to contain an assembly manifest.
Thank you very much!
Posted 11-Jul-11 4:05am
Edited 11-Jul-11 4:28am
wizardzz104.9K
v2
Comments
SAKryukov at 11-Jul-11 16:04pm
   
Not enough information.
--SA
Syed Salman Raza Zaidi at 12-Jul-11 3:34am
   
might be because of Framework version is different
musefan at 12-Jul-11 4:15am
   
Does your application crash straight away? or after some time? What does your application do? I have seen BadImageFormatException for memory leaks too, specifically when doing custom drawing (OnPaint event etc.) and not disposing images when using them in a PictureBox (or similar)

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Have you included any dll in your application which is protected against deployment with the public key RSA encryption?
I think that some thing like than may cause this error.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Sergey Alexandrovich Kryukov 888
1 OriginalGriff 420
2 CPallini 275
3 George Jonsson 226
4 Richard Deeming 145
0 OriginalGriff 5,450
1 CPallini 4,500
2 Sergey Alexandrovich Kryukov 4,272
3 George Jonsson 3,057
4 Gihan Liyanage 2,445


Advertise | Privacy | Mobile
Web02 | 2.8.140916.1 | Last Updated 18 Jul 2011
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100