Click here to Skip to main content
12,401,984 members (59,002 online)
Rate this:
 
Please Sign up or sign in to vote.
See more: C# C#4.0
Microsoft JScript runtime error: AjaxControlToolkit requires ASP.NET Ajax 4.0 scripts. Ensure the correct version of the scripts are referenced. If you are using an ASP.NET ScriptManager, switch to the ToolkitScriptManager in AjaxControlToolkit.dll.

Actually 2 versions of ajax are referred:version 2.0 and 4.1


I have given in web config runtime tag:

assemblyidentity name="Sys.Extended.UI" publickeytoken="28f01b0e84b6d53e" culture="neutral" 
bindingredirect oldversion="2.0.5.0" newversion="4.1.40412.0" 


Still then also,in one form with collapsiblepanelextender ,its showing the above mentioned error and Sys.Extended.UI is null.

how to solve this?
Posted 27-Sep-11 0:13am
RoshInd676
Updated 27-Sep-11 15:31pm
v4

1 solution

Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

Please try this.

change this

<asp:ScriptManager ID="ScriptManager1" runat="server" />

to this

<cc1:ToolkitScriptManager ID="ToolkitScriptManager1" runat="server"></cc1:ToolkitScriptManager>
  Permalink  
v2
Comments
RoshInd 27-Sep-11 6:27am
   
I have already given this:
<ajaxToolkit:ToolkitScriptManager ID="ToolkitScriptManager2" runat="server" EnablePartialRendering ="true">
Member 11265187 29-Jan-15 7:34am
   
but the error still remain after changing
<asp:ScriptManager ID="ScriptManager1" runat="server" />
to
<cc1:ToolkitScriptManager ID="ToolkitScriptManager1" runat="server">

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Mobile
Web02 | 2.8.160721.1 | Last Updated 28 Feb 2013
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100