Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: VC6
Hi,
 
I was doing remote system file access (i.e., Writing a file in remote machine & reading the same file from that machine). For that I established a connection using
WNetAddConnection2 
 
It works fine while I run it directly in my account.
But while launching from system account (i.e., Launching from service, using pstool (or) registered in services.msc) it is not working.
 
It returns with an error code of 1312 from GetLastError(), means
NO_SUCH_LOGON_SESSION
 

How should I proceed now?
 
Please help me..
 
Thanks & regards,
Yugeshkumar V
Posted 18-Dec-11 22:53pm

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

System account doesn't have access to network resources so you should use some account which have privileges top access network (like yours does).
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 230
1 PIEBALDconsult 150
2 DamithSL 125
3 Andreas Gieriet 90
4 Jochen Arndt 90
0 OriginalGriff 5,790
1 DamithSL 4,601
2 Maciej Los 4,012
3 Kornfeld Eliyahu Peter 3,480
4 Sergey Alexandrovich Kryukov 3,195


Advertise | Privacy | Mobile
Web02 | 2.8.141220.1 | Last Updated 19 Dec 2011
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100