Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C#2.0 ASP.NET
Hello Experts,
 
I upload my website to server but it generate an error. It is working fine on local machine.
 
Please help me regarding this error.
 

 
erver Error in '/' Application.
 
Configuration Error
 
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.
 
Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.
 
Source Error:
 

Line 24:                <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
Line 25:                <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/></assemblies></compilation>
Line 26:        <authentication mode="Forms">
Line 27:            <forms loginUrl="~/Account/Login.aspx" timeout="2880"/>
Line 28:        </authentication>
Posted 18-Jan-12 18:42pm
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 4

Hi, if you ever encounter this error
 
Quote:
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS

 
SOLUTION
I had the same issue with VS 2012.
I resolved this by
 
1. Unload your current project
2. edit your .csproj
3. Find this
<mvcbuildviews>false</mvcbuildviews>
4. Instead of false change the value to true
5. Load again your project and you should not have any more this error
 
If you do have then one solution is to delete the content of the obj folder in the project generated by compiler.
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 5

VS.NET 2005 was complaining about a configuration section within the web.config file in the Backup folder of my application...just remove (or move) the backup folder so it doesn't have a web.config file under the Virtual directory that your ASP.NET 2.0 application is running in.
 
It worked for me Smile | :)
  Permalink  
v2
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

Hi,
 
The Issue is very common while working in hosting environment and dealing with clients website issues, finally i prepared a post by myself for future references and To help hosting administrators.I posted it on my blog, you may check the below URL to check:
 
Visit http://blog.geek4support.com
 
Thanks
 
Geek4Support_Admin
http://blog.geek4support.com
  Permalink  
v2

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Maciej Los 295
1 OriginalGriff 249
2 Sergey Alexandrovich Kryukov 205
3 Aajmot Sk 197
4 Sinisa Hajnal 176
0 OriginalGriff 7,800
1 Sergey Alexandrovich Kryukov 7,072
2 DamithSL 5,604
3 Manas Bhardwaj 4,986
4 Maciej Los 4,790


Advertise | Privacy | Mobile
Web02 | 2.8.1411023.1 | Last Updated 29 May 2014
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100