Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: ASP.NET HTML HTML5
hi..
i had added html5 video tag to my asp.net but it does not work
and in stead of video a big X appears in the video content.
but when i use the same tag in other html file created by notepad and run it ,every thing work correctly ,i tested it in (IE9-firefox 8-chrome-safari-opera) and not working please help me.
Posted 21-Jan-12 4:33am
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

Please, keep checking the browser's layout engine against HTML5 support: http://en.wikipedia.org/wiki/Comparison_of_layout_engines_%28HTML5%29[^].
 
From the table shown in the above article you will see that the Trident engine (http://en.wikipedia.org/wiki/Trident_%28layout_engine%29[^]) used in IE still sucks Smile | :) .
 
There is one work-around: you can change the default Web browser used by Visual Studio.
 
You can find out how to do it in many places:
http://www.hanselman.com/blog/HowToChangeTheDefaultBrowserInVisualStudioProgrammaticallyWithPowerShellAndPossiblyPokeYourselfInTheEye.aspx[^],
http://stevenharman.net/blog/archive/2007/08/02/setting-a-default-browser-for-visual-studio.aspx[^],
http://bit.ly/zK0Pa6[^].
 
This totally solves the problem of rendering right features during development, but think if you really need it. First, this can create a problem with the code debugger (not a big deal, it can only disrupt JavaScript debugging which still can be used with some other browsers if tuned properly). Not a big problem anyway as you can get back to IE at any time.
 
More importantly, do you really need those HTML5 features if IE does not support them? How about your users using IE? Anyway, you decide.
 
—SA
  Permalink  
v2
Comments
CPallini at 21-Jan-12 19:03pm
   
My 5.
SAKryukov at 21-Jan-12 19:13pm
   
Thank you,
--SA
Espen Harlinn at 22-Jan-12 7:19am
   
5'ed!
SAKryukov at 22-Jan-12 13:06pm
   
Thank you, Espen.
--SA
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Sadly, microsoft still won't implement open standards driving you into the arms of google...
 
https://tools.google.com/dlpage/webmmf[^]
 
Good luck!
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

If it works when you write the code by hand, then compare the generated code with the code you wrote by hand. Also, ensure that the link is valid and that the video is encoded by a supported codec.
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 4

If you want to use it go with Google chrome.....Make it default Browser in Visual Studio Settings.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 499
1 Maciej Los 325
2 Sergey Alexandrovich Kryukov 234
3 DamithSL 233
4 Mathew Soji 195
0 OriginalGriff 7,168
1 Sergey Alexandrovich Kryukov 6,377
2 DamithSL 5,461
3 Manas Bhardwaj 4,876
4 Maciej Los 4,450


Advertise | Privacy | Mobile
Web01 | 2.8.1411023.1 | Last Updated 24 May 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100