Click here to Skip to main content
11,648,094 members (61,978 online)
Rate this: bad
good
Please Sign up or sign in to vote.
See more: Web-Development icon
I have a web page and a 'favicon.ico' in the same directory.

I am using this code to point to the icon.
<link rel="icon" href="favicon.ico" type="image/x-icon"/>
<link rel="shortcut icon" href="favicon.ico" type="image/x-icon"/>

All things being equal I should have the favicon showing in the tab, and yet it isn't.

I have cleared the cache and restarted the browser, yet still it is not showing.

Anthing obvious that I am missing?
Posted 4-Feb-12 11:43am
Dalek Dave433.2K
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Have you tried putting the full URL in the href ?
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

Which browser? IE? check out the table(s) in below page.

Check this wiki page http://en.wikipedia.org/wiki/Favicon[^]
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 jyo.net 500
1 F-ES Sitecore 370
2 DamithSL 300
3 OriginalGriff 277
4 CPallini 250
0 OriginalGriff 1,342
1 jyo.net 994
2 DamithSL 981
3 Sergey Alexandrovich Kryukov 893
4 CPallini 845


Advertise | Privacy | Mobile
Web03 | 2.8.150804.4 | Last Updated 4 Feb 2012
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100