Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: Win2003 Apache
I hvae installed an Apache-Tomcat 6.0.35 on a win-2003 server and with quite a lot of effort, I got it working, mostly! Then I enable the SSI and can see the command
like

<!--#echo var="date_local" -->
 
<!--#exec cmd="net start MSSQL\$TRANS" -->
 
etc. working. The net start command gave me confidence that something is working.
And I can start the net service as well.
 
Then when I try:
 
<!--#exec cmd="dir /b" -->
 
I got nothing print out! Similar command in Linuxmint with cmd="ls" seem work!
 
Furthermore, I set file myshell.bat with just a dir command and then try:
 
<!--#exec cgi="cig-bin\\myshell.bat" -->
 
and it would me error in executing the directive.   I have setup the cig-bin and the
shell file myshell.bat to be executable by Internet user.
 
Can anyone help?
Posted 26-Feb-12 3:25am
KFLee485

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 CHill60 210
1 Sergey Alexandrovich Kryukov 200
2 Peter Leow 180
3 Zoltán Zörgő 175
4 Richard Deeming 166
0 Sergey Alexandrovich Kryukov 9,278
1 OriginalGriff 6,806
2 Peter Leow 4,432
3 Zoltán Zörgő 3,944
4 Richard MacCutchan 2,782


Advertise | Privacy | Mobile
Web01 | 2.8.150129.1 | Last Updated 26 Feb 2012
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100