Click here to Skip to main content
11,806,575 members (67,810 online)
Rate this: bad
Please Sign up or sign in to vote.
See more: Win2003 Windows Apache
I hvae installed an Apache-Tomcat 6.0.35 on a win-2003 server and with quite a lot of effort, I got it working, mostly! Then I enable the SSI and can see the command

<!--#echo var="date_local" -->

<!--#exec cmd="net start MSSQL\$TRANS" -->

etc. working. The net start command gave me confidence that something is working.
And I can start the net service as well.

Then when I try:

<!--#exec cmd="dir /b" -->

I got nothing print out! Similar command in Linuxmint with cmd="ls" seem work!

Furthermore, I set file myshell.bat with just a dir command and then try:

<!--#exec cgi="cig-bin\\myshell.bat" -->

and it would me error in executing the directive.   I have setup the cig-bin and the
shell file myshell.bat to be executable by Internet user.

Can anyone help?
Posted 26-Feb-12 2:25am

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 ppolymorphe 205
1 OriginalGriff 175
2 Richard Deeming 175
3 Sergey Alexandrovich Kryukov 170
4 Abhinav S 120
0 OriginalGriff 3,380
1 Maciej Los 1,990
2 CPallini 1,915
3 KrunalRohit 1,907
4 ppolymorphe 1,317

Advertise | Privacy | Mobile
Web01 | 2.8.151002.1 | Last Updated 26 Feb 2012
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100