Click here to Skip to main content
11,927,324 members (59,492 online)
Rate this:
Please Sign up or sign in to vote.
See more: Dev Firefox Cache
Dear all,
I want to turn off firefox caching, i have try :
<meta http-equiv="expires" content="0">
<meta http-equiv="cache-control" content="no-cache">
<meta http-equiv="pragma" content="no-cache">


but it does not work, please help me!
Posted 10-Apr-12 19:11pm
Rate this: bad
Please Sign up or sign in to vote.

Solution 1

Try this:

<META HTTP-EQUIV="Cache-Control" CONTENT="max-age=0">
<META HTTP-EQUIV="Cache-Control" CONTENT="no-cache">
<META http-equiv="expires" content="0">
<META HTTP-EQUIV="Expires" CONTENT="Tue, 01 Jan 1980 1:00:00 GMT">
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
NguyenVanDuc 11-Apr-12 0:24am
It does not work :(
Rate this: bad
Please Sign up or sign in to vote.

Solution 2

1. Opened up the FireFox browser
2. Typed about:config in the address bar
3. Typed ‘cache’ in the search bar, and looked for: network.http.use-cache.
4. Double clicked network.http.use-cache in order to set it to false. (BTW, Double clicking it again will set it to true and re-enable the cache)

Happy coding Smile | :)
NguyenVanDuc 11-Apr-12 0:26am
How can i cofig it? in VB code or Aspx ? or config directly in Fire fox, i want to turn off in server side. Please make me clearly!
vishal_h 7-Feb-14 0:17am
Thanks guy but i am also searching for the same but not get solution and above code is working fine for IE but not for Firefox.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy | Mobile
Web04 | 2.8.151126.1 | Last Updated 11 Apr 2012
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100