Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: IIS dotnetnuke
Hi Friends,
 
Error:
 
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.
 
Properties:
 
Module IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x80070021
Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
Config File \\?\C:\inetpub\wwwroot\DNN5.06.03\web.config
Requested URL http://localhost:80/DNN5.06.03
Physical Path C:\inetpub\wwwroot\DNN5.06.03
Logon Method Not yet determined
Logon User Not yet determined
 
Config Source:
79:     </modules>
80:     <handlers>
81:       <remove name="WebServiceHandlerFactory-Integrated"/>
 
Someone please give me the solution for this error?
 
Thanks,
Posted 23-May-12 21:28pm

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

IIS 7 implements "Configuration Locking". This is to help with IIS administration.
 
Here, look at the error details and how to resolve the same: IIS 7 – This configuration section cannot be used at this path.[^]
 
As per it, one of the resolution:
1. Open the applicationHost.config file, located here: %windir%\system32\inetsrv\config\applicationHost.config
2. Edit the "handlers" section.
3. Change this line:
    <section name=”handlers” overrideModeDefault=”Deny” />
    To:
    <section name=”handlers” overrideModeDefault=”Allow” />
  Permalink  
Comments
Afzal Shaikh at 24-May-12 3:22am
   
1. Handlers line does not exist in web.config file.
2. There is no IIS Admin here , i am running this on localhost...
 
Read that article provided by you but no luck :(
Afzal Shaikh at 24-May-12 3:33am
   
Yes , Got it... I had to change in the applicationHost.config file...
it is working now but new error has been generated which is
 
HTTP Error 404.3 - Not Found
The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.
 

It is possible that a handler mapping is missing. By default, the static file handler processes all content.
The feature you are trying to use may not be installed.
The appropriate MIME map is not enabled for the Web site or application. (Warning: Do not create a MIME map for content that users should not download, such as .ASPX pages or .config files.)
If ASP.NET is not installed.
Sandeep Mewara at 24-May-12 4:08am
   
I told that you need to modify applicationHost.config.
 
Now, you have different issue to troubleshoot. Use aspnet_regiis.exe to register version of .NET framework you are using.
http://msdn.microsoft.com/en-us/library/k6h9cz8h%28VS.80%29.aspx
 
Also look at this link if it helps: http://blogs.msdn.com/b/rjohri/archive/2009/06/29/the-page-you-are-requesting-cannot-be-served-because-of-the-extension-configuration.aspx
Afzal Shaikh at 24-May-12 4:22am
   
Thanks Sandeep,I am posting another question for extension issue so others can see as well
 
Thanks,
Sandeep Mewara at 24-May-12 4:31am
   
Ok. Do add what exactly are you doing and the environment.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



Advertise | Privacy | Mobile
Web03 | 2.8.150326.1 | Last Updated 24 May 2012
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100