Click here to Skip to main content
11,428,876 members (61,648 online)
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C++
Hello,

Cximage - HistogramEqualization () is not working ?</b>

i am having 64bit machine - but i am working on 32 VS2010 and using Cximage 7 version.

This is my CODE for CXimage ..

CxImage Obj;
Obj.Load(_T("D:\\IPImages\\1.jpg"),CXIMAGE_FORMAT_JPG);


i can do other image processing operations such as Negative,Histogram Stretch,like etc..
But HistogramEqualization is not working .
Obj.HistogramEqualize();
 
Obj.Save(_T("D:\\Mobile_IPImages\\CXOut.jpg"),CXIMAGE_FORMAT_JPG);

Its not throwing any errors. but the save image is empty Frown | :(

Please Let me know / help me out ..any one has faced the problem ????
Posted 28-May-12 17:57pm
Pixel86323
Comments
JF2015 at 28-May-12 23:52pm
   
you already asked that question in the forum for the CP article. Please don't post twice.
Pixel86 at 29-May-12 1:11am
   
ok , sorry

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

I think you use grayscale JPEG. Check BPP.

if (Obj.GetBpp() == 8)
{
Obj.IncreaseBpp(24);
Obj.HistogramEqualize();
Obj.GrayScale();
}
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



Advertise | Privacy | Mobile
Web04 | 2.8.150428.2 | Last Updated 16 Feb 2015
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100