Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
Hi,
While saving the large images in Sql Server-2008 R2 database from Silverlight 4.0 desktop application I am gettimg the below error.
 
The HTTP request to 'http://<your URL>' has exceeded the allotted timeout. The time allotted to this operation may have been a portion of a longer timeout.
 
Please help me out if possible with the suitable example.
Posted 4-Jun-12 21:06pm
Comments
SASS_Shooter at 5-Jun-12 10:59am
   
You need to change the timeouts on the server. Look in the web.config for the server behavior.

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Hi Mayank,
I think you need to manually set the timeout values in binding settings of your web.config file. By default it'll be a 1 minute, you should have to increase it.
 
For (ex),
 bindings>   <basichttpbinding>     <binding name="IncreasedTimeout" sendtimeout="00:25:00">     </binding>   </basichttpbinding>
 
There are several timeouts like closeTimeout,openTimeout etc. you can set these values as per your need.
 
Regards,
Bluesathish
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 350
1 Jochen Arndt 150
2 Richard MacCutchan 135
3 PIEBALDconsult 110
4 Sergey Alexandrovich Kryukov 104
0 OriginalGriff 6,055
1 DamithSL 4,621
2 Maciej Los 4,087
3 Kornfeld Eliyahu Peter 3,500
4 Sergey Alexandrovich Kryukov 3,294


Advertise | Privacy | Mobile
Web02 | 2.8.141220.1 | Last Updated 15 Jun 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100