Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
I am getting this strange issue while building the solution.
Reference required to assembly 'App_Web_nameofusercontrol.ascx.cc671b29.9faev84c, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' containing the type 'projectname.nameofusercontrol'. Add one to your project.

We don't have any assembly of this kind and sometimes solution is getting built without any issue at all. This solution contains 5 projects and the name of the assemble matches with one of the user control. Tried clearing the temporary asp.net files but still the same issue. Any suggestions ? Thanks.
Posted 5-Jun-12 5:35am
Edited 5-Jun-12 6:07am
Mehdi Gholam249.7K
v2

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

this is a very old problem with cached dlls on compilation with asp.net web sites.
 
the trick is usually to clear cache/restart IIS/recycle app pool etc.
 
also check a bit online.
 
http://stackoverflow.com/questions/425015/asp-net-wcf-and-could-not-load-file-or-assembly-app-web-hamznvwf[^]
 
http://blogs.creative-jar.com/post/Could-not-load-file-or-assembly-App_Web_.aspx[^]
  Permalink  
Comments
learner'sbug at 5-Jun-12 12:33pm
   
Thanks.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 587
1 Sergey Alexandrovich Kryukov 519
2 Maciej Los 305
3 BillWoodruff 250
4 Mathew Soji 195
0 OriginalGriff 7,356
1 Sergey Alexandrovich Kryukov 6,777
2 DamithSL 5,461
3 Manas Bhardwaj 4,916
4 Maciej Los 4,475


Advertise | Privacy | Mobile
Web01 | 2.8.1411023.1 | Last Updated 5 Jun 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100