Click here to Skip to main content
11,927,187 members (45,305 online)
Rate this:
Please Sign up or sign in to vote.
I am getting this strange issue while building the solution.
Reference required to assembly 'App_Web_nameofusercontrol.ascx.cc671b29.9faev84c, Version=, Culture=neutral, PublicKeyToken=null' containing the type 'projectname.nameofusercontrol'. Add one to your project.

We don't have any assembly of this kind and sometimes solution is getting built without any issue at all. This solution contains 5 projects and the name of the assemble matches with one of the user control. Tried clearing the temporary files but still the same issue. Any suggestions ? Thanks.
Posted 5-Jun-12 5:35am
Edited 5-Jun-12 6:07am
Mehdi Gholam292.5K

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

this is a very old problem with cached dlls on compilation with web sites.

the trick is usually to clear cache/restart IIS/recycle app pool etc.

also check a bit online.[^][^]
learner'sbug 5-Jun-12 12:33pm

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy | Mobile
Web02 | 2.8.151126.1 | Last Updated 5 Jun 2012
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100