Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: IIS7 Visual-Studio Win7 Errors , +
I try to debug my web service with IIS7. It doesn't start and throws an error.
 
"Unable to start debugging on the web server. The remote debugging components are not registered or running on the web server. Ensure the proper version of msvsmon is running on the remote computer."
 
my application is built in visual studio 2008 and my PC OS is windows 7 64bit.
IIS is installed on this machine.
 
I googled this issue but all the solutions comes for visual studio 2010 and I am using visual studio 2008.
 
and what it means 'remote computer' indicating in error while the application and IIS are on the same machine?
 
please, tell me the proper solution.
 
Thanks in advance.
Posted 15-Jul-12 22:55pm
ashriv947
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

First of all, make sure you’re application pool is running the correct .NET Version:
  • .NET 2.0, 3.0 and 3.5 web applications, should use an application pool that uses .NET 2.0
  • .NET 4.0 web application, should use an application pool that uses .NET 4.0
 
Now, based on the configuration and error, it looks like: Visual Studio 2008 is running under WOW64 on your 64 bit machine and thus it needs remote debugging to connect between WOW64 and the 64-bit application on machine. Thus, to debug on the 64 bit machine, you might need to make sure the remote debugging components are installed correctly. Following article should help:
MSDN: How to: Debug 64-Bit Applications[^]
 

If that does not help, post it, follow this MSDN article to troubleshoot it and see if it helps: MSDN: Error: Unable to Start Debugging on the Web Server[^]
  Permalink  
Comments
ashriv at 16-Jul-12 5:50am
   
Thanks Sandeep.
but all those solutions not worked for me.
I am using .Net 2.0 Application pool.
I gone through these steps but problem is not resolved -
- I started msvsmon though this problem is not resolved.
- Re-registered the .Net Framework version
- Enabling windows authentication mode.
- In web.config file, set debug = true
 
1 week ago, this is running correctly. so, please suggest me any other steps..
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 4

1) Right click on your project in VS2005 or VS2008 or VS2010.
2) 2) Click on Properties
3) 3) Click on Web tab
4) 4) Under Servers, click on the radio button Use Visual Studio Development Server
5) Check Auto Assign Port radio button
5) 6) Uncheck NTLM Authentication and Enable Edit and Continue
 

above one in resolve my issued
Cheers!
  Permalink  
Comments
Member 11154039 at 28-Oct-14 4:12am
   
thank's dear
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 5

There could be many possible solution for this based on your situation you have. I think you can try this post. Having solution for all possible cause for this.
 
Unable-to-start-debugging-on-the-web-server-The-project-is-not-configured-to-be-debugged
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

I did these two things and Issue resolved -
 
1. Enable 32-bit application settings set as True.
for this , right click on
Application Pool -> Advance Setting -> Enable 32 bit Application -> TRUE
 
2. Assign this Application Pool to my project Virtual directory.
 
There are some other solutions which I found from Net but that did not work in this case.
- Started msvsmon.
- Re-registered the .Net Framework version
- Enabling windows authentication mode.
- In web.config file, set debug = true
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Sergey Alexandrovich Kryukov 334
1 Kornfeld Eliyahu Peter 325
2 Maciej Los 239
3 OriginalGriff 188
4 King Fisher 185
0 OriginalGriff 6,303
1 DamithSL 4,764
2 Maciej Los 4,306
3 Kornfeld Eliyahu Peter 3,914
4 Sergey Alexandrovich Kryukov 3,538


Advertise | Privacy | Mobile
Web03 | 2.8.141220.1 | Last Updated 16 Feb 2014
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100