Click here to Skip to main content
11,629,285 members (67,076 online)
Rate this: bad
good
Please Sign up or sign in to vote.
See more: ASP.NET SQL-Server WebForms , +
i have the following error in my web application server log files, and its happens permanently.
A transport-level error has occurred when receiving results from the server. (provider: TCP Provider, error: 0 - The semaphore timeout period has expired.)" 
and the next one too :
A transport-level error has occurred when sending the request to the server. (provider: TCP Provider, error: 0 - An existing connection was forcibly closed by the remote host.)
any help please.
Posted 30-Jul-12 20:35pm
Edited 30-Jul-12 21:05pm
Mehdi Gholam282.4K
v2
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Try increasing your connection timeout property (default is 30 sec) : http://msdn.microsoft.com/en-us/library/system.data.sqlclient.sqlconnection.connectiontimeout.aspx[^]

Or your command timeout property (default is 30 sec): http://msdn.microsoft.com/en-us/library/system.data.sqlclient.sqlcommand.commandtimeout.aspx[^]
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

Hi,
check your Connection string
Best Regards,
Pandu.
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

Hi ..


Please set time out high ...
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS


Advertise | Privacy | Mobile
Web03 | 2.8.150723.1 | Last Updated 31 Jul 2012
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100