Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: iPhone Android HTML5
Hi,
 
I am doing some R & D about making a simple HTML5 app. However I am very much new to any mobile app. While working on it, I come to know about two tools, which can help me to make this app.
1. Titanium
2. PhoneGap
 
I am using Titanium, installed it on my Windows7 machine. What else I have is JDK 1.6, Safari and google Chrome latest browser, which are capable of HTML5 web pages.
 
I couldn't find any proper tutorial startring from declaring create Project in titanium. Still I tried a lot, but its damn fustrating. Its giving a huge error list, and I have no idea how to get id of it.
 
In Titanium support forum, the people who are using the same Windows7 os, facing the same issue and they have their own fix. But none of them working in my case.
 
My error is like..
 
Quote:
[INFO] logfile = D:\MobileAppsDemos\demo1\build.log
[INFO] Launching Android emulator...one moment
[ERROR] 'xcopy' is not recognized as an internal or external command,
[ERROR] operable program or batch file.
[ERROR] Exception occured while building Android project:
[ERROR] Traceback (most recent call last):
[ERROR] File "C:\Users\DPA\AppData\Roaming\Titanium\mobilesdk\win32\2.1.1.GA\android\builder.py", line 2229, in
[ERROR] s.run_emulator(avd_id, avd_skin, avd_name, avd_abi, add_args)
[ERROR] File "C:\Users\DPA\AppData\Roaming\Titanium\mobilesdk\win32\2.1.1.GA\android\builder.py", line 485, in run_emulator
[ERROR] avd_name = self.create_avd(avd_id, avd_skin, avd_abi)
[ERROR] File "C:\Users\DPA\AppData\Roaming\Titanium\mobilesdk\win32\2.1.1.GA\android\builder.py", line 408, in create_avd
[ERROR] available_avds = avd.get_avds(self.sdk)
[ERROR] File "C:\Users\DPA\AppData\Roaming\Titanium\mobilesdk\win32\2.1.1.GA\android\avd.py", line 23, in get_avds
[ERROR] for line in run.run([sdk.get_android(),'list','target'],debug=False).split("\n"):
[ERROR] AttributeError: 'NoneType' object has no attribute 'split'

 

Then after some time in Console i got this..
 
Quote:
[INFO] logfile = D:\MobileAppsDemos\demo1\build.log
[INFO] Building demo1 for Android ... one moment
[INFO] Titanium SDK version: 2.1.1 (07/27/12 14:01 0fd84a2)
[ERROR] Application Installer abnormal process termination. Process exit value was 1
[ERROR] Timed out waiting for emulator to be ready, you may need to close the emulator and try again

 

No emulator displayed. Where I am doing mistake. Please anyone can help me out???
Posted 28-Aug-12 2:08am
comred1.2K

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Sergey Alexandrovich Kryukov 458
1 OriginalGriff 344
2 George Jonsson 233
3 Animesh Datta 130
4 Shemeemsha RA 128
0 OriginalGriff 6,179
1 Sergey Alexandrovich Kryukov 5,616
2 CPallini 4,770
3 George Jonsson 3,400
4 Gihan Liyanage 2,522


Advertise | Privacy | Mobile
Web02 | 2.8.140916.1 | Last Updated 28 Aug 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100