Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
In my asp.net project break points are not hitting, even I have checked all debug settings, running it into debug mode as well.
 
When I drop a break-point on hover it shows message
"The break point will not currently be hit.No Symbols have been loaded for this document."
 
Thanks in Advance.
Posted 3-Sep-12 3:35am
Comments
0x0005h121 at 3-Sep-12 9:45am
   
Can paste the code you want to debug ??
Dasaradhi_r at 6-Sep-12 7:27am
   
Is your problem solved?
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

  Permalink  
v2
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

Following are some of the reasons why your Visual studio will not hit break points.
1) Project is not fully built: For this you clean your solution and make a rebuild.
Still if it is not hitting, right click on the break point, Click Location and
in the dialog that opens, Check the check box (Allow the source code to be
different from original version)
 
2) The break point is not in the code execution path: For this, ensure you have
put the break point in the right place. Put the break point at the starting of
the event/method, Should not be inside a condition or elsewhere. Also, put the
break point immediately in the Page_load.
 
3) Debug is not enabled in the application: In your web.config ensure that
following is present:< compilation debug="true"/>
 
4) You are trying to debug unmanaged code:
1.From the project properties page, in the debug tab, make sure we tick the
checkbox, "Enable unmanaged code debugging"
 
2.From the menu Tools->Options, navigate to Debugging node, uncheck the
checkbox "Enable Just My Code".
 
3.Make sure you provide the correct pdb files of the VC6 executable of dll.
 
Please see the below links if you still have issues:
http://blogs.msdn.com/b/sudeepg/archive/2007/08/13/why-the-debugger-will-not-hit-your-breakpoints.aspx[^]
 
http://weblogs.asp.net/guybarrette/archive/2008/10/08/the-breakpoint-will-not-currently-be-hit.aspx[^]
  Permalink  
Comments
Squall83 at 10-Jul-13 7:51am
   
Thank you, you just made my day! I forgot to turn on the "Enable unmanaged code debugging" function and searched for hours.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

This happens when PDB file is missing or an old one, not updated. Compiled DLL and the respective PDB file needs to be of same timestamp. You need to make sure that the DLL last modified date and PDB last modified dates are in sync. PDB files are the one responsible that helps you in debugging.
 
Clean the solution and rebuild all. This should create a new dll along with PDB. Once done, you should be able to debug it.
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 4

What worked for my ASP.NET project on vs2010 is: I ran my ASP.NET project which debugged in internet explorer 10 since it's my default web browser, on the ie10 browser; I unchecked File/Work offline. Try this solution, hope it works for all of you who are having the same problem.
  Permalink  
Comments
Member 3355287 at 7-Jan-14 23:13pm
   
May be it is too late but in VS2012 check Test&gt;TestSettings&gt; "LocalTestRun.TestRunConfig" is checked, uncheck it and it will stop skipping the code lines.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Sergey Alexandrovich Kryukov 838
1 OriginalGriff 461
2 Tadit Dash 355
3 sanket saxena 329
4 Peter Leow 228
0 Sergey Alexandrovich Kryukov 11,990
1 OriginalGriff 7,349
2 Peter Leow 5,003
3 Abhinav S 4,003
4 Maciej Los 3,575


Advertise | Privacy | Mobile
Web04 | 2.8.140421.2 | Last Updated 7 Feb 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Use
Layout: fixed | fluid