Click here to Skip to main content
11,410,750 members (64,406 online)
Rate this: bad
good
Please Sign up or sign in to vote.
See more: VB.NET
dear friends

when i use webcam in my vb.net application first time it is working, but second time when i close and open form it will show a message window "Vedio Source" with three button
OK, Cancel, Apply
with combo box "Select a vedio Device"

Please Help me ,How can i come over this problem, this problem come only in "Window 7 OS"
Posted 4-Sep-12 23:24pm

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

I have the same problem - there's some kind of freeing/initialization step being missed. I don't know what it is either. To fix, I just open a webpage with a flash control that accesses the camera. It seems to reset it every time. I downloaded a file that's just called 'myCamera.swf' (no idea where from, sorry) it's only 384 bytes. I just drag and drop it into an open browser window, wait for this video preview to appear then close it. Voila! The camera work when I open the app. (app not running when using the swf file)
  Permalink  
Comments
ravi kumar86 at 5-Sep-12 5:29am
   
but this is not a right solution for our problem
enhzflep at 5-Sep-12 5:36am
   
Cool. Question bookmarked. I want the answer too.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Sergey Alexandrovich Kryukov 239
1 Sascha Lefévre 85
2 Dave Kreskowiak 80
3 Maciej Los 68
4 RyanDev 50
0 Sergey Alexandrovich Kryukov 8,885
1 OriginalGriff 6,915
2 Maciej Los 3,390
3 Abhinav S 3,248
4 Peter Leow 3,059


Advertise | Privacy | Mobile
Web04 | 2.8.150414.5 | Last Updated 5 Sep 2012
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100