Click here to Skip to main content
12,454,477 members (56,774 online)
Rate this:
 
Please Sign up or sign in to vote.
See more: ADO.NET
Dear Friends,
Just Yesterday When I tried to Add an EDM file (New Item) to my Project I got Error.
This is The Image File of the Error I've Captured from my Desktop.
http://imageshack.us/a/img211/4388/newpicturebk.png[^]

And This is the Error what I got:
Could not resolve mscorlib for target framework
'.NETFramework,Version=v4.0,Profile=Client'.This can happen if the
target framework is not installed or if the framework moniker is
incorrectly formatted.


Plz Check Out What's wrong & provide me a Solution ASAP.
Also I've Tried Re-Installing .NET Framework.Also Repaired VS2010.But no Use.

Thanks,
Dash
Posted 14-Sep-12 4:48am
Updated 14-Sep-12 5:09am
v2
Comments
Wes Aday 14-Sep-12 10:54am
   
So you automatically exlude people from helping you that cannot see the picture.
Gittu Dash 14-Sep-12 10:59am
   
Sorry Bro I didn't Get U.
Image Is Showing Me Well.
This is d image:
[IMG]http://imageshack.us/a/img211/4388/newpicturebk.png[/IMG]
Wes Aday 14-Sep-12 11:01am
   
What is there to get? Not everyone can see images posted to other web sites. I cannot see the image because it is blocked so you automatically exclude people from helping you.
Gittu Dash 14-Sep-12 11:13am
   
Okay Sorry.
Now I've Added the Text what i got as Error.
Plz Check it & tell Me What's d Error ??

Thanks for Showing Interest
Wes Aday 14-Sep-12 16:02pm
   
http://stackoverflow.com/questions/5498624/visual-studio-2010-could-not-resolve-mscorlib-for-target-framework-netframewo, I think your problem is probably related to the third one down.
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

Do you have the correct version of the .NET framework installed?
  Permalink  
Comments
Gittu Dash 14-Sep-12 15:49pm
   
Yes I've v4.0 which I'm using in Project
Jonathan [Darka] 14-Sep-12 16:52pm
   
I meant the client profile version as it's looking for that.

http://stackoverflow.com/questions/3579951/net-framework-4-0-client-profile-vs-net-framework-4-0
Gittu Dash 15-Sep-12 9:09am
   
Yes I've The Correct Version.
Now Can U plz Tell Me Is It Possible that This Thing will happen if Multiple Versions of Framework present ???

Actually Some Days back I've tried to install v4.5 Beta.but the Installation Failed.
Jonathan [Darka] 17-Sep-12 4:36am
   
Did you check Wes's reply above?
Gittu Dash 17-Sep-12 16:58pm
   
Yeah Checked Properly.
Even I Uninstalled VS2010 completely from My System & Re-Installed it.But still I'm Getting d Problem.

I Can't create EDM Item & Can't add Service reference Still..
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 3

I Simply Uninstalled VS2010 & Installed VS2011 Beta & It Worked.
  Permalink  
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 2

Well Guys.I've installed VS2011 Beta on My PC & All The Problems Solved, means I'm not getting any kind of Error I've mentioned.

So Now Can U plz Guide me what was d Issue ??
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Mobile
Web02 | 2.8.160826.1 | Last Updated 24 Sep 2012
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100