Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C# Visual-Studio Win2008-R2 , +
Hi,
 
Im am trying to deloy an application using clickonce from visual studio 2010 on development computer to my Win2008 Server. However i am getting errors.
 
I first tried to use IIS, when publishing to the server IIS, it says 'web server Frontpage server extension doesnt exist'.
 
Upon some advise on blogs, i tried to use FTP to deploy. then it says '..could not find web server'.
 
Anyone with some advise on how to publish to a server using clickonce?
 
Kind Regards
 
Nicole
Posted 19-Sep-12 0:45am
nikki88752
Edited 19-Sep-12 0:48am
v3

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

This isn't a complete solution, but it may be a step on the way...
 
I would try doing a click once deployment to some non-server target first, to confirm that I've got my click once setup right. I suspect that the target being a server is not the root problem, but that your click once setup isn't quite right.
 
If you don't have access to a spare non-server machine, you might be able to set up a virtual machine on your dev box and use it as a test target.
  Permalink  
Comments
nikki88 at 19-Sep-12 10:10am
   
You seem to be spot on, I tired to deploy the application to another machine. It gives me a similar error.
 
So then how do i deploy the app to somewhere other than the local host? I currently 'create a new web application' on the local IIS and publish it there. i.e http://..machinename.../WebSite/
Chris Ross 2 at 19-Sep-12 11:38am
   
Sadly I've never actually set up an app for Click Once, so I can't share any wisdom. Google is perhaps your friend for learning how to set it up.
 
We do use Click Once for the deployment of the app I work with, and we use web deployment (but it was set up before I arrived).
 
Here are the settings (publish tab of the project) - which perhaps will shed some light:
Publishing folder location: \\intranet01\d$\wwwroot\SomeWebSiteName\TheAppName\
Installation folder URL: http://SomeWebSiteName/
* The app is available offline as well.
 
Hope that helps.
nikki88 at 21-Sep-12 7:10am
   
Google is failing me now.. but i'll push on :) i suspect Windows server 2008 is the problem.
 
I will try what you have; using a shared folder for publishng and a Website as URL.
 
Thanks for your help.
 
Enjoy your day.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 520
1 Maciej Los 290
2 Richard MacCutchan 265
3 BillWoodruff 265
4 Suraj Sahoo | Coding Passion 155
0 OriginalGriff 8,764
1 Sergey Alexandrovich Kryukov 7,437
2 DamithSL 5,639
3 Maciej Los 5,279
4 Manas Bhardwaj 4,986


Advertise | Privacy | Mobile
Web01 | 2.8.1411028.1 | Last Updated 19 Sep 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100