Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: IIS6 ASP.NET
Hi Friends,
Quote:
"Error 1053: The service did not respond to the start or control request in a timely fashion"

 
These days, im facing above problem while working with windows server 2003.
When i upload precompiled file to IIS and run command iisreset then it's stop working and my application is giving me an error like "Internet cannot display web page."
 
Now, if i do stop it and restart then its giving above error (quoted text) and showing me cross red mark (X) on websites folder.
One solution i got is to restart the server.. but dont want to do it everytime in future.
 
thanks
Posted 20-Sep-12 3:30am
Comments
Wes Aday at 20-Sep-12 9:09am
   
Then find out which service is failing to start and fix it.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Here you go:
You receive an "Error 1053: The service did not respond to the start or control request in a timely fashion" error message when a service that uses the local system account tries to start on a Windows Server 2003-based computer
[^]
 
Let me just quote the cause. Go through the link for solution and other details.
 
Services that use the local system account to log on to a Microsoft Windows Server 2003-based computer do not start. By default, services such as the following use the local system account to log on:
 
    World Wide Web Publishing Service
    Microsoft Windows Installer
    Microsoft Windows Management Instrumentation
  Permalink  
Comments
Dev.Vikas.S at 24-Sep-12 1:45am
   
now, if i don't run iisreset command then at sharp 5.30pm Service goes off and application starts showing message like "Internet cannot display the webpage"
i just failed to find out which servise goes off at 5.30pm till now.
Ankur\m/ at 25-Sep-12 13:50pm
   
Check the logs in the event viewer. It might have something for you. Also check the pool recycle settings. The application pool usually recycles at a particular time interval.
I would suggest you to have a sys admin configure these things properly.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

Quote:
Hello there
 
First check services.msc to ensure that you have a working service called w3svc , if you don't ,it seems that your world wide web publishing service is not working or it missed from your server due to installation error , so to fix up go with one of the following solutions.
 
1- Reinstall iis using a different windows server 2003 media
 
OR
 
2- Extract the world wide web service from a working iis server and import it in your server -which is unable to start iis and aaplication pool.(to do that: in the working server that you want to extarct the w3svc from it , open regedit , expand to HKLM\SYSTEM\CurrentControlSet\Services\W3SVC , right click on w3svc and export to a file with .reg extension , copy this file to your target server , backup it's current registry , import the mentioned file above in the you target server , restart)
now you the working version of your w3svc strted at your services.msc consol.
 
Congratulations , you have a working application pool and iis server now
 
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

One of possible reason for this problem [It fixed issue at my end]:
 
If you are using Debug code as below in your service the problem may arise.
 
#if(!DEBUG)
ServiceBase[] ServicesToRun;
ServicesToRun = new ServiceBase[]
{
new EmailService()
};
ServiceBase.Run(ServicesToRun);
#else
//direct call function what you need to run
#endif
 

To fix this, while you build your windows service remove #if condition because it didn't work as it is.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 7,105
1 DamithSL 5,079
2 Maciej Los 4,866
3 Sergey Alexandrovich Kryukov 4,617
4 Kornfeld Eliyahu Peter 4,384


Advertise | Privacy | Mobile
Web03 | 2.8.141223.1 | Last Updated 20 Nov 2014
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100