Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C# 64-bit VisualStudio
before, I run a visual studio express 2008 version on 32bit, now I move it to 64bit, and it gives the following error:
The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine
 
someone says that OLEDB 4 is not supported or compatible with 64bit.
 
then someones suggests change the target platform from any CPU to x86, unfortuantely, in visual studio express version, no such choice.
 
anyone has some suggestion?
 
by the way, I found microsoft intends to fool us.
Posted 23-Sep-12 3:45am
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

There is indeed no 64 bit version of Jet - and no plans (apparently) to produce one.
 
You might be able to use the ACE 64 bit driver: http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=23734[^] - but I have no idea how that would work if you need to go back to Jet for your 32 bit apps.
 
However, you may be able to switch the project to 32bit in the Express version (I haven't tried and don't have 2008 installed in any flavour anymore) - there is a thread here that talks about it: http://xboxforums.create.msdn.com/forums/t/4377.aspx#22601[^]
 
Maybe it's time to scrap Access databases altogether, bite the bullet and go for SQL server instead?
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

You can set VB.Net 2008 to compile x86. Menu Tools, Options, select Progects And Solutions, check the show advanced build configurations. Now in the Build Menu you will be able to go to the Cofig Manager and set output to x86.
  Permalink  
v2
Comments
YOGESH GANGWAR at 28-Aug-14 12:37pm
   
I have Visual Studio 2010 installed on my system. I also face the same problem i.e. "The Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine.". After setting output to x86 in place of x64, the problem gets resolved.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 4

The Microsoft.Jet.OLEDB.4.0 provider is not registered on the local machine
Background
 
Amphis Customer is designed to work on 32 or 64 bit PCs running Windows XP, Windows Vista, Windows 7 or Windows 8 Pro, but on Windows XP 64 bit (and possibly other operating systems) it is possible that some of the Microsoft OLEDB DLLs have not been registered.
 
The Solution No. 1. :-p
 
The solution is to manually register those DLLs.
 
go to Start->Run and type cmd
this starts the Command Prompt
(also available from Start->Programs->Accessories->Command Prompt)
 
type cd .. and press return
type cd .. and press return again (keep doing this until the prompt shows :\> )
 
now you need to go to a special folder which might be c:\windows\system32 or it might be c:\winnt\system32 or it might be c:\windows\sysWOW64
try typing each of these eg
cd c:\windows\sysWOW64
(if it says The system cannot find the path specified, try the next one)
cd c:\windows\system32
cd c:\winnt\system32
when one of those doesn't cause an error, stop, you've found the correct folder.
 
now you need to register the OLE DB 4.0 DLLs by typing these commands and pressing return after each
 
regsvr32 Msjetoledb40.dll
regsvr32 Msjet40.dll
regsvr32 Mswstr10.dll
regsvr32 Msjter40.dll
regsvr32 Msjint40.dll

Solution No. 2 :p

 
To resolve this issue open the project in Visual Studio then:
 
1. From the solution explorer right-click your project then click Properties
2. Click the Build tab
3. Change Platform target from: Any CPU to x86
4. Re-build your solution
 
By Shishir Kumar
Research Nilman Team (RNT)
  Permalink  
Comments
richcb at 9-Aug-13 11:40am
   
Nice solution. The second one did the trick for me.
1suresh at 28-Aug-13 15:30pm
   
It saved my time and really worked.. thanks for tht..
rambabujalli at 17-Nov-13 11:19am
   
The second solution worked for me,
thanks a lot dear
Member 10496240 at 5-Jan-14 23:29pm
   
thank you it works..
Member 10504327 at 10-Jan-14 18:36pm
   
It works! :D
jose.aroca at 29-May-14 16:38pm
   
great answer
Nilesh C at 2-Jul-14 13:27pm
   
Nice solution. The second one did the trick for me too.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

I use two different machines for my automated testing. One is 64-bit Windows 7 and one is 32-bit Windows 7. Both run VS2010 Ultimate using an Access 2010 database for storing and retrieving the input data used by the scripts. My project (common to both machines) uses Provider .NET Framework Data Provider for OLE DB, so my database connection string is this...
 
Provider=Microsoft.ACE.OLEDB.12.0;Data Source=C:\...
 
Never had any problem with either machine.
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 5

I tried with this suggestion it work http://social.msdn.microsoft.com/Forums/office/en-US/94dad202-d964-468a-a0b5-3102b5ea31eb/the-microsoftjetoledb40-provider-is-not-registered-on-the-local-machine (go to properties in project solution explorer => Build => Platform target=x86)
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 6

ACE requires Access runtime engine, I think, whereas if a Jet solution can be contrived, there is no requirement to have Access present on the local machine, since Jet (used to) come with Windows.
 
Thus I would hope that Solutions 1 and 2 continue to work for a long, long time. If not, my solution road map will probably suffer great harm.
 
I don't know of anything that works with minimal licenses like Excel & Jet solutions, with ADO as the connectivity library and JRO as the database management library.
 
I am still looking, it seems critical to stay on top of this rather then get left for dead by MS.
 
Bill Benson
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 7

I had this same problem occur all of a sudden and it wasn't a "Jet" problem as it previously worked, and then stopped working. As it turned out, the application pool that the site was running under had "Enable 32-bit applications" changed to "False". When I changed back to "True", the OleDb error went away.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Sergey Alexandrovich Kryukov 487
1 CPallini 345
2 OriginalGriff 240
3 George Jonsson 159
4 Abdul Samad KP 145
0 OriginalGriff 6,329
1 Sergey Alexandrovich Kryukov 5,700
2 CPallini 4,940
3 George Jonsson 3,469
4 Gihan Liyanage 2,522


Advertise | Privacy | Mobile
Web03 | 2.8.140916.1 | Last Updated 29 Jul 2014
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100