Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
hi,
 
I am successfully loaded user control dynamically on AJAX tab container
here is the code
 
1)
Dim UserControl_3 As ASP.inpatienteditbill_ascx = New ASP.inpatienteditbill_ascx
 
2)
UserControl_1.LoadControl("~/InpatientEditBill.ascx")
  TabPanel3.Controls.Add(UserControl_3)
 
Question is,
 
I have lots of controls with in user controller, such as grid view, drop downs, buttons...
 
when I click the button in user control its disappear, and when click on the tab its get loaded, but the form load event doesn't get invoke.
plz help me.
Posted 23-Sep-12 22:13pm
v2

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

hi,
might be it is problem of postback..check out that..
when u click on button within user control then page is postback then usercontrol disappears but when u click on tab then it load usercontrol again...
  Permalink  
Comments
sawshalin at 24-Sep-12 4:22am
   
post backs are working fine,when i bind them to main page source,

uc3:WebUserControl3 ID="WebUserControl3" runat="server"

what i need is load user controls dynamically(already done),but form load event of user control is not firing and when click the button on user control its get lost

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Maciej Los 347
1 DamithSL 305
2 ridoy 278
3 OriginalGriff 224
4 George Jonsson 140
0 OriginalGriff 7,968
1 DamithSL 6,179
2 Sergey Alexandrovich Kryukov 5,524
3 Maciej Los 5,438
4 Kornfeld Eliyahu Peter 4,539


Advertise | Privacy | Mobile
Web04 | 2.8.141223.1 | Last Updated 24 Sep 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100