Click here to Skip to main content
12,510,860 members (53,629 online)

MVC and buttons not working

Unsy asked:

Open original thread
Hi guys

I'm new to MVC, so forgive me if this sounds like a silly question:

I am building an application using the template that comes with VS2010 and MVC4 using Razor. My problem is buttons... I have tried
<input type="submit" name="value" value="value" />
<button type="submit" name="value" value="value">Test</button>

but neither of these do anything. No postback screen refresh or anything.

Can anyone tell me what I am missing? It seems like it should be so simple, yet I'm tearing my hair out over this...

As far as I am aware, there should be nothing that would disable these.

Thanks
Tags: C# (C#4.0), MVC4

Preview



When answering a question please:
  1. Read the question carefully.
  2. Understand that English isn't everyone's first language so be lenient of bad spelling and grammar.
  3. If a question is poorly phrased then either ask for clarification, ignore it, or edit the question and fix the problem. Insults are not welcome.
Let's work to help developers, not make them feel stupid.
Please note that all posts will be submitted under the The Code Project Open License (CPOL).



Advertise | Privacy | Mobile
Web02 | 2.8.160929.1 | Last Updated 26 Mar 2009
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100