Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: Javascript HTML
check whether javscript is enable or not in html form
Posted 8-Oct-12 21:46pm
bhargavpp1.5K
Comments
enhzflep at 9-Oct-12 2:54am
   
Yes, it is enabled.
bhargavpp at 9-Oct-12 3:09am
   
e popat,read my question carefully
Narra sreenu at 9-Oct-12 6:42am
   
Try to put your question clearly here.
bhargavpp at 10-Oct-12 7:08am
   
go home and sleep well...
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

<script>
  alert("JavaScript is enabled.");
</script>
 
<noscript>
  JavaScript is not enabled or not supported.
</noscript>
  Permalink  
Comments
bhargavpp at 12-Oct-12 8:24am
   
not working...
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

This should work too. If the JavaScript on the browser is disabled it will output a message and a link on how to enable it.

<noscript style="font-size: 18px; color: red; font-weight:bold">Javascript is disabled:<a href="https://www.google.com/adsense/support/bin/answer.py?hl=en&amp;answer=12654"target="_blank">Click here to learn how to enable it before continue.</a>&nbsp;<br/></noscript>
  Permalink  
Comments
bhargavpp at 12-Oct-12 8:24am
   
not working..
Bryian Tan at 12-Oct-12 12:34pm
   
What is not working?
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

  Permalink  
Comments
bhargavpp at 12-Oct-12 8:24am
   
showing always javascript is enable
JJ Raj at 12-Oct-12 20:15pm
   
if you don't how to test it please accept it.. Did you disable javascript before testing? For which zone you have disabled it? there is internet intranet trustedsite zones?
bhargavpp at 13-Oct-12 1:04am
   
yes i have tested on Mozilla,Chrome,IE9,Opera but not getting result it is always showing true,if i am disabling then also showing true..
JJ Raj at 13-Oct-12 1:18am
   
In IE9 Did you go to internet options -> Security -> Internet -> custom options -> Disable Active scripting? I tested in IE9 today morning it works.. Tell me how did you disable javascript in IE9?
bhargavpp at 13-Oct-12 1:48am
   
yes exectly i have done the same but application not running and message showing is always true as per your code detail..
JJ Raj at 13-Oct-12 1:57am
   
Did you do the "disable active scripting" for both internet and intranet security options.. I had the same problem when did only for Internet when disabled Intranet also its working for me...
bhargavpp at 13-Oct-12 2:02am
   
may be your broser not working propery so please check that and then try it i have tried lots of time but still same issue

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Sascha Lefévre 485
1 Sergey Alexandrovich Kryukov 325
2 Maciej Los 240
3 Abhinav S 164
4 Peter Leow 120
0 Sergey Alexandrovich Kryukov 6,953
1 OriginalGriff 6,311
2 Maciej Los 2,732
3 Peter Leow 2,674
4 Abhinav S 2,562


Advertise | Privacy | Mobile
Web03 | 2.8.150414.1 | Last Updated 11 Oct 2012
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100