Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
Hello Friends,
I am using crystal report XI to show my project reports but i have trouble when i open my reports in visual studio. it was give me this error "The operation could not be completed. Class not registered."
Can any one please help me about this problem as soon as possible.
Thank you........
Posted 10-Oct-12 5:52am
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Try repairing or reinstalling Crystal for VS2008.
 
The error may occur because the crystal DLL's are not properly registered.
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

You may have the same problem as is described here: http://stackoverflow.com/questions/5642220/vs2010-the-operation-could-not-be-completed-class-not-registered-when-trying[^]. The solution is to update registry entries.
  Permalink  
Comments
tanisha pandey at 13-Oct-12 4:04am
   
i follow this link but again i have same problem. i was put (-) after 5 character to update registry but it will not work. i show you the path of my registry "HKEY_CURRENT_USER/Software/Microsoft/VisualStudio/9.0/Registration" and in that registration i got params value. where i put dash(-) after every 5 character to update registry. Is this correct or wrong? give me detail advice. thank you.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 235
1 Sergey Alexandrovich Kryukov 144
2 Rob Philpott 100
3 Peter Leow 70
4 CHill60 70
0 OriginalGriff 6,902
1 Sergey Alexandrovich Kryukov 5,623
2 Maciej Los 3,479
3 Peter Leow 3,373
4 DamithSL 2,505


Advertise | Privacy | Mobile
Web01 | 2.8.140721.1 | Last Updated 11 Oct 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100