Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C#4.0 ASP.NET4.0
hi friends,
my code is working in local..In server i am getting the above error.
 
If i insert image very first time it works fine..if i update i am getting the above error In Remote Server only..it's working in local ..below is my code
if (FileUpload1.HasFile)
                  {
                      System.Drawing.Image UploadedImage = System.Drawing.Image.FromStream(FileUpload1.PostedFile.InputStream);
                      if (UploadedImage.Width < 100 || UploadedImage.Height < 150)
                      {
                          string filename = Guid.NewGuid().ToString().Substring(0, 10);
                          string extension = FileUpload1.PostedFile.FileName.Remove(0, FileUpload1.PostedFile.FileName.LastIndexOf("."));
                          FileUpload1.SaveAs(Server.MapPath(Request.ApplicationPath) + "/ProviderImages/" + (filename + extension));
                          string path = Server.MapPath(Request.ApplicationPath) + "/ProviderImages/" + (filename + extension);
                          string path1 = Server.MapPath(Request.ApplicationPath) + "/ProviderImages/" + ("tmp" + filename + extension);
                          if (ThumbNailGenerator.GenerateThumbNail(path, path1) == true)
                          {
                              if (HiddenField1.Value != null)
                              {
                                  if (File.Exists(Server.MapPath(Request.ApplicationPath + "/ProviderImages/" + HiddenField1.Value)))
                                  {
                                      File.Delete(Server.MapPath(Request.ApplicationPath + "/ProviderImages/" + HiddenField1.Value));
 
                                      if (File.Exists(Server.MapPath(Request.ApplicationPath + "/ProviderImages/" + "tmp" + HiddenField1.Value)))
                                      {
                                          File.Delete(Server.MapPath(Request.ApplicationPath + "/ProviderImages/" + "tmp" + HiddenField1.Value));
                                      }
                                  }
 
                              }
 
                              updateproviderrequest.Provider.Company.CompanyLogo = filename + extension;
                              FileUpload1.FileContent.Dispose();
 
                              updateproviderresponse = providerservice.Update(updateproviderrequest);
                          }
                      }
                     
 
please help me
 
Thanks in advance
Posted 26-Oct-12 22:17pm

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

UploadedImage.Dispose() is missing in the end.
 
So the handle is being help by your application.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 315
1 Jochen Arndt 190
2 DamithSL 125
3 PIEBALDconsult 110
4 Garth J Lancaster 90
0 OriginalGriff 5,790
1 DamithSL 4,601
2 Maciej Los 4,012
3 Kornfeld Eliyahu Peter 3,480
4 Sergey Alexandrovich Kryukov 3,195


Advertise | Privacy | Mobile
Web04 | 2.8.141220.1 | Last Updated 18 Apr 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100