Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
I have to retrieve some data from database and show them in report viewer in windows application.
I use VS2010 and SAP Crystal report for VS2010.My database is SQL Server 2008 R2 which installed with VS2010.
I create my database and did not set any password for my database anywhere. In my connection strings I use:
bla;bla;bla;Integrated security = true;
I Add a dataset to my program called LibraryDatase.xsd. The report use this xsd file to get data but in runtime it need password? but I did not set any password anyWhere!!
In runtime the password dialog has a checkbox for integrated security and that not work too?
I have no idea what password should I enter?
Any help please
Posted 30-Oct-12 3:35am
Comments
Sushil Mate at 30-Oct-12 8:37am
   
why don't you provide the password of your sql server at design time?
calcushtag at 30-Oct-12 8:43am
   
I have no password. I didnot set any password for sqlserver anywhere. I use windows authentication
Sushil Mate at 30-Oct-12 9:42am
   
it should work.try to create one user or give the "SA" account's credentials. Hope it solves the problem.
sinhasourabh at 30-Oct-12 9:26am
   
From where you are executing your code ? from IIS or Local machine.
calcushtag at 30-Oct-12 9:35am
   
It's a windows form application.. local machine
Guirec Le Bars at 30-Oct-12 12:11pm
   
Is the user (windows account) trusted to access SQL Server?

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

You don't specifically say this in your question, but I assume that the problem you are having is that you keep getting prompted to enter logon info when displaying your report. If that is the case, try setting all of the logon info dynamically in code before calling the report.
Here is an article on that:
csharp crystal reports dynamic login[^]
(I assume that you'd just set the password to an empty string since you didn't set it.)
 
If that is not your issue, please include whatever error message you are getting or describe what exactly is happening. Does it give you an error message? What code do you have right now to display your report?
  Permalink  
Comments
calcushtag at 30-Oct-12 16:27pm
   
But what is the user name and password. I have no problem with getting login prompt. My problem is I have no idea what is my Username and Password. If I can pass the login prompt I can pass it with code. Assume the passwors is a blank string, then what is the username?
Kschuler at 30-Oct-12 16:40pm
   
What exactly is asking for a username/password? The crystal report? The database? What? Because now I'm confused. If it's the crystal report, try just blanks or set the DataSourceConnection using the path, database and set IntegratedSecurity to false.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 George Jonsson 175
1 Kornfeld Eliyahu Peter 169
2 Zoltán Zörgő 139
3 PIEBALDconsult 130
4 OriginalGriff 120
0 OriginalGriff 6,165
1 DamithSL 4,658
2 Maciej Los 4,107
3 Kornfeld Eliyahu Peter 3,649
4 Sergey Alexandrovich Kryukov 3,342


Advertise | Privacy | Mobile
Web04 | 2.8.141220.1 | Last Updated 30 Oct 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100