Click here to Skip to main content

dsagner asked:

Open original thread
[ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
Parameter name: site]
   System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags, PolicyLevel policyLevel, Exception appDomainCreationException) +298
 
[HttpException (0x80004005): Specified argument was out of the range of valid values.
Parameter name: site]
   System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +9873912
   System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +101
   System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +254
 
This is the error each time I want to "View in Browser", or run debugging from Visual Studio 2012. Can anyone read out the problem in this stacktrace?
By the way, I have tried to view the site in Page Inspector, the result I get says that no mapping data was returned from the server.
 
The error itself repeats itself for any project i start in VS2012.
Working on windows 7 64 bit!
 
EDIT:
Just hit me, I did have some minor fault while installing vs2012. What happened is that during the installation a small time error popped out saying that some component, tool or something named like visual studio 2010 toolkit or something similar can not be found. Some file like vs...04 was missing. Skipped it, install finished and everything seemed to be ok.
 
EDIT:
Re-started the installation to found out which was the file that was causing the problem. It was vstor40_x64.msi (Visual Studio 2010 Tools for Office Runtime)!
Does this identify as the problem-cause for the stacktrace when trying to debug/view in browser?
 
EDIT:
About to reinstall VS2012, downloaded the vstor40_x64.exe from microsoft's site, and installed it, all went well for now.
 
EDIT:
Reinstall did nothing, same problem. I did notice although that the error page states at the bottom:
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.17929
That is for all I know .NET 4! I checked the property page in VS12 and it is set to 4.5. Help me out here Smile | :) ...
Tags: VB (VB.NET), ASP.NET, WebForms, Web-Development, HTTP, web.Config

Preview



When answering a question please:
  1. Read the question carefully.
  2. Understand that English isn't everyone's first language so be lenient of bad spelling and grammar.
  3. If a question is poorly phrased then either ask for clarification, ignore it, or edit the question and fix the problem. Insults are not welcome.
Let's work to help developers, not make them feel stupid.
Please note that all posts will be submitted under the The Code Project Open License (CPOL).



Advertise | Privacy | Mobile
Web02 | 2.8.141015.1 | Last Updated 26 Mar 2009
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100