Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: WPF ListView
Hi guys ,
My problem is after delete an entity from the database my listview did not updated
please can you help me
Thanks
Posted 18-Nov-12 3:08am

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Hi, Try this
 
1. Bind your ListView with an
ObservableCollection<t></t>
in XAML or at runtime with the Listview property ItemSource
2. Load your Data From your database in this ObservableCollection object you created
3. After Deleting the the entity in your database you have 2 choice. fisrt delete the entity directly from your ObservableCollection object (better performance but will ingnore change made by other user if your application run in an network environnement ) or second Reload your Data From your database in then ObservableCollection object.
 

HOPE IT'S HELP
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Gihan Liyanage 332
1 Sergey Alexandrovich Kryukov 330
2 ClimerChinna 222
3 vikinghunter 168
4 OriginalGriff 166
0 Sergey Alexandrovich Kryukov 8,363
1 OriginalGriff 7,112
2 CPallini 2,598
3 Richard MacCutchan 2,025
4 Abhinav S 1,788


Advertise | Privacy | Mobile
Web04 | 2.8.140827.1 | Last Updated 18 Nov 2012
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100