Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: PowerShell
When I run the New-ADUser command through a script, I get the error, but if I run the exact same command in the same powershell session, it works fine and I don't get the error. The rest of the script runs fine, I have started the session normally and as Administrator.
Posted 20-Nov-12 10:12am
graybin387
Comments
Sergey Alexandrovich Kryukov at 20-Nov-12 15:19pm
   
How exactly did you run as Administrator? Just logging as administrator would not be enough. There could be another access problem, of course, from AD side where you might not have sufficient privilege for the account which is just the local admin...
--SA

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

I know this thread is old, but I thought I would post what I found.
There's a security feature in Win2K8 that prevents you from running these cmdlets locally on a DC using Domain Admins only account.
 
I added my AD account to the following groups:
Administrators
Domain Admins
Enterprise Admins
Schema Admins
 
Not sure which one it needed, but I was able to get it working.
 
Cheers Smile | :)
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Sergey Alexandrovich Kryukov 555
1 Kornfeld Eliyahu Peter 409
2 Maciej Los 359
3 DamithSL 196
4 OriginalGriff 188
0 OriginalGriff 6,353
1 DamithSL 4,854
2 Maciej Los 4,466
3 Kornfeld Eliyahu Peter 4,058
4 Sergey Alexandrovich Kryukov 3,897


Advertise | Privacy | Mobile
Web02 | 2.8.141220.1 | Last Updated 20 Dec 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100