Click here to Skip to main content
12,505,341 members (76,145 online)
Rate this:
 
Please Sign up or sign in to vote.
See more: VB VB.NET VS2012
I am new to Visual Studio. I have published my first VB.Net Windows Application on a Windows 7 machine using VS2012 Express and VB.NET. It installs and runs on the development machine but when I try to install it on a Vista machine it aborts. As soon as I run Setup there is a quick flash of a small window and then nothing. No error message is given. I changed the target machine from any CPU to X86 but that had no affect on the problem.

Any assistance would be appreciated.
Posted 19-Dec-12 1:45am
Comments
ryanb31 19-Dec-12 7:59am
   
Did you check the event viewer? Are logs created?
joshrduncan2012 19-Dec-12 9:17am
   
It probably needs dlls to make Vista happy. What types of files are in your setup?
Abhishek Pant 19-Dec-12 15:18pm
   
your vista was hungry so.. ate those files.. :laugh: ; need to install .net framework 4 in that system.
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

Setup of your application? What did you create the Setup with?? Did you include ALL the files that the Setup needs?? What version of the .NET Framework did you application target?? Is that version of the .NET Framework installed BEFORE you run your setup??
  Permalink  
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 2

Thanks for your help. I went to the Event Viewer and it would not load either. I repaired the OS and all is well now. Thanks again for your input.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Mobile
Web02 | 2.8.160927.1 | Last Updated 19 Dec 2012
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100