Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C# ASP.NET
sir,

My project structure is as bellow,

Solution 'ab.ABCD'(4project)
>D:\project\ABCD.web\
>App_Code
>--------
>--------
>Bin
>Pages
>--------
:
>web.config
>ab.ABCD.BLL
>Properties
>References
>HomeServices.cs
:
>ab.ABCD.DAL
>Properties
>References
>Read.cs
:
>ab.ABCD.Util
>Properties
>References

As per the refference How to use log4net[^]
I inserted the bellow code in web.config under D:\project\ABCD.web\

<configSections>
    <section name="log4net" type="log4net.Config.Log4NetConfigurationSectionHandler, log4net" />
</configSections>
 
<log4net debug="true">
    <appender name="RollingLogFileAppender" type="log4net.Appender.RollingFileAppender">
        <file value="C:\\TestProj\\TestLog.txt" />
        <appendToFile value="true" />
        <rollingStyle value="Size" />
        <maxSizeRollBackups value="10" />
        <maximumFileSize value="10MB" />
        <staticLogFileName value="true" />
        <layout type="log4net.Layout.PatternLayout">
            <conversionPattern value="%-5p %d %5rms %-22.22c{1} %-18.18M - %m%n" />
        </layout>
    </appender>
 
    <root>
        <level value="DEBUG" />
        <appender-ref ref="RollingLogFileAppender" />
    </root>
</log4net>
 

Where i need to put the code
'[assembly: log4net.Config.XmlConfigurator(ConfigFile="Web.config", Watch=true)]'
?
 
Regards,
Arif Tk
Posted 8-Jan-13 19:11pm
ariftk1.6K
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Inside the Properties you will get the file "AssemblyInfo.cs"
  Permalink  
Comments
ariftk at 9-Jan-13 6:38am
   
There is no Properties under D:\project\ABCD.web\
IpsitaMishra at 9-Jan-13 23:56pm
   
you have mention in your qns itself
 
>ab.ABCD.DAL
>"Properties"
>References
>Read.cs
:):)
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

Previously D:\project\ABCD.web\ was in the website format so that there was no file like Properties/AsemblyInfo.cs.Now i converted website to web application,now it is working fine.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 5,380
1 Sergey Alexandrovich Kryukov 4,693
2 Peter Leow 2,939
3 DamithSL 2,465
4 Maciej Los 2,230


Advertise | Privacy | Mobile
Web01 | 2.8.140718.1 | Last Updated 13 Jan 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid