Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C# ASP ASP.NET
Hi everybody,

All the aplication works great in the localhost, but when I publish the aplication in IIS (Win2008) any control with the AjaxControlToolKit doesn't Work...
 
In this photo you can see the modalpopup.... http://imageshack.us/photo/my-images/534/mals.jpg/

Thanks for your help.
Posted 10-Jan-13 12:42pm

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

When I was using the toolkit, I had to build and compile it to produce the DLL files I needed for my projects. I had to build 2 versions, for for 2.0/3.5 and 4.0.
 
I had to be careful to use the correct versions needed.
 
So you just grab the correct version of the DLL's, and make a Bin Folder for your website project, and drop the files in the Bin Folder.
 
make sure your reference for the toolkit points to the bin folder, all should be good from there.
 
I just looked at your image, I've seen that before in where the server renders the toolkit different.
 
I noticed that the script manager renders the toolkit different than the AjaxToolkit script manager, in the way it handles masking and the centering of the modal popup. ScriptManager works correct.
 
That was annoying, I finally dumped the toolkit for Jquery, and use simple modal now.
 
Try The ScriptManager tag element if your using the AjaxScriptManager tag element.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 484
1 Peter Leow 443
2 Sergey Alexandrovich Kryukov 288
3 Kornfeld Eliyahu Peter 270
4 Maciej Los 230


Advertise | Privacy | Mobile
Web04 | 2.8.150301.1 | Last Updated 10 Jan 2013
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100