Click here to Skip to main content
12,446,296 members (54,843 online)
Rate this:
 
Please Sign up or sign in to vote.
Hello folks,

I have an app,created in visual studio 2008.

Runs fine on XP and my 7 systems.

However on some win7 computers my dialogs do not open.

the standard open/save dialogs do work.

But my own dialog windows that have to open when a button is clicked do not work.

I added the redist to my installation file, without luck...

CMydialogDlg dlg1;
dlg1.init(this);
dlg1.language = language;
dlg1.DoModal();


void CMydialogDlg::init(CMyappDlg *d)
{
	parent = d;
}
 
BOOL CMydialogDlg::OnInitDialog()						
{
	CDialog::OnInitDialog();
 
	SetLanguage(language);
	m_Set_Button.EnableWindow(false);
	
 
	
	return TRUE;  // return TRUE unless you set the focus to a control
	              // EXCEPTION: OCX Property Pages should return FALSE
}

any ideas are welcome...

Thanks in advance

Blob dlg
Posted 23-Jan-13 21:53pm
Updated 23-Jan-13 23:08pm
v2
Comments
OriginalGriff 24-Jan-13 4:41am
   
This is not a good question - we cannot work out from that little what you are trying to do.
Remember that we can't see your screen, access your HDD, or read your mind.
Use the "Improve question" widget to edit your question and provide better information.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Mobile
Web02 | 2.8.160811.3 | Last Updated 24 Jan 2013
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100