Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C# Win7 WebService IIS7.5
Hi ,
Can anybody tell me how to host a web application on IIS7.5 in windows 7.
 
When I'm trying to do so. I'm getting following error.
 

 
Error Summary
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.
 
Please help.
 
Thank you.
Posted 28-Jan-13 19:45pm
Dee_Bee3.5K
Edited 6-Feb-13 22:42pm
v2
Comments
Edo Tzumer at 29-Jan-13 1:11am
   
Where are you getting the error?
and
What do you "how to create a URL"?
   
what is the exactly thing you want ???
 
Do you need to create the URL using any lang. or IIS ???
Dee_Bee at 29-Jan-13 4:09am
   
I need to create URL using IIS 7.5
Michiel du Toit at 6-Feb-13 8:06am
   
You're going to have to provide more details on the error you're getting. Windows 7 has default settings in place that stops some standard IIS stuff from working by default - these settings just needed to be changed.
 
Some changes in your %windir%\Microsoft.NET\Framework\v____\config's files are required to allow application web.configs to enable HttpModules, etc - without knowing which your web app requires we can't point you in the right direction...
Krunal Rohit at 7-Feb-13 4:48am
   
http://www.dotnetfunda.com/articles/article1247-how-to-host-aspnet-application-on-the-web-server-iis.aspx

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Ahmm,
 
The message is saying that your configuration file is corrupt in some way. However it also says that it can't actually access the config file. So I'd ignore the original message about corruption/lack of validity as this is most likely just the effect of not being able to read the file due to a lack of authorization.
 
The reason it cannot read the config file is because the process running your web app does not have permission to access the file/directory. So you need to give the process running your web app those permissions.
 
The access rights should be fairly straightforward, i.e. at least Read, and, depending on your app, maybe Write.
 
The file web.config should only be accessible through your application.
 

Option:
Perhaps the asp.net account does not appear in the IIS manager, if so, in windows 7 follow the steps:

- Open control panel
- Click on” program” link (not uninstall programs)
- Click” turn windows features on/off” link
- locate” Internet Information services IIS” in the pop up window and expand its node
- Expand the” World Wide Web Service” node
- Expand “Application Development Features” node
- check the check box of”ASP.NET”
- Then click ok button
 

[by Intermension]
 
Cheers,
Edo
  Permalink  
v3

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Maciej Los 205
1 Richard MacCutchan 185
2 DamithSL 170
3 Tomas Takac 146
4 OriginalGriff 132
0 OriginalGriff 5,130
1 DamithSL 4,237
2 Maciej Los 3,700
3 Kornfeld Eliyahu Peter 3,470
4 Sergey Alexandrovich Kryukov 2,846


Advertise | Privacy | Mobile
Web04 | 2.8.141216.1 | Last Updated 7 Feb 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100