Click here to Skip to main content
12,549,181 members (51,211 online)
Rate this:
Please Sign up or sign in to vote.
See more: C# ASP.NET
Hello friends..
I have made one website..and working successfully on my server.but the problem is when i installed same website on client machine on his server then its working properly but not generating crystal report and giving me error like no records found..
I reinstalled visual studio on client machine..i have installed same version of sql and visual studio on client side which i m using on my server..but still not working it..please give me solution of it...its urgent..
Thanks in advance...
Posted 30-Jan-13 18:49pm
Nandakishorerao 31-Jan-13 0:58am
check whether there is the crystal reports installed or not..generally, crystal reports are not used in websites. because, many web hosters does not have the support to the crystal reports since it is third party tool.
Aysha Patel 31-Jan-13 1:14am
I have already installed crystal reports..and we not using third party control..
Nandakishorerao 31-Jan-13 1:22am
have you verified the tables and its value...if you are binding using dataset try to verify it again. uid and pwd may be the reason.
Aysha Patel 31-Jan-13 1:29am
yes i have cheked it..correct password and uid
Nandakishorerao 31-Jan-13 1:32am
is it populating the dataset..verify in the ssms or in the debugging mode..whether the data is getting populating or not?
Rate this: bad
Please Sign up or sign in to vote.

Solution 1

Please tell me error Number in Hex Format .

or Install

Crystal report runtime in Client end .

"CRRedist2008_x86.msi" (for 32bit)

"CRRedist2008_x64.msi" (for 64bit)

Please try it will resolve your issue you can find Crytal report runtime of vs 2010 , vs 2008 but on client end the above will be okay.
Aysha Patel 31-Jan-13 5:08am
should i have to make any change in web config too???
Rate this: bad
Please Sign up or sign in to vote.

Solution 2

You just copy all the crystal reports from project file and paste into bin->debug->x86 and paste here.The crystal report will work.
Aysha Patel 31-Jan-13 5:03am
i didnt get your answer ...can u please elabrote it...because i have 35 crystal reports in my website..
Balamurugan1989 31-Jan-13 5:12am
Open your project file in that you will be having crystal reports copy all your crystal reports and paste in your debug->x86.It will work...
Aysha Patel 31-Jan-13 5:28am
there is no such debuge->x86 in my project...
Balamurugan1989 31-Jan-13 6:08am
coul u sen ur project file......

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy | Mobile
Web02 | 2.8.161021.1 | Last Updated 31 Jan 2013
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100